Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157361 - cross arch obsoletes are ignored by rpm
Summary: cross arch obsoletes are ignored by rpm
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
: 170571 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 21:51 UTC by Ben Levenson
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-02 17:56:02 UTC


Attachments (Terms of Use)

Description Ben Levenson 2005-05-10 21:51:54 UTC
Description of problem:
rpm ignores obsoletes statements across arch.

bug 157194 is an example of this.

openoffice.org-style-gnome is obsoleted by the latest openoffice.org packages:
# rpm -q --obsoletes openoffice.org-1.1.2-24.2.0.EL3
openoffice
openoffice.org-style-gnome

but the openoffice.org-style-gnome package wasn't removed during upgrade:
# rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" openoffice.org
openoffice.org-style-gnome
openoffice.org-1.1.2-24.2.0.EL3.i386
openoffice.org-style-gnome-1.1.0-16.9.EL.x86_64

Version-Release number of selected component (if applicable):
rpm-4.2.3-13

Comment 2 Radek Bíba 2005-10-25 16:54:20 UTC
*** Bug 170571 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2005-11-02 17:56:02 UTC
Yup. Obsoletes: are same color (i.e. elf32 can obsolete elf32, not elf64)
, as requested by yum et al depsolvers.

Comment 4 Jeff Johnson 2007-04-11 12:16:16 UTC
Please add comments to

    https://lists.dulug.duke.edu/pipermail/rpm-devel/2007-April/002260.html


Note You need to log in before you can comment on or make changes to this bug.