Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157360 - yum install wxPythonGTK2.i386 finishes but installation is bad
Summary: yum install wxPythonGTK2.i386 finishes but installation is bad
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wxPythonGTK2
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 21:25 UTC by Nir
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 12:01:21 UTC


Attachments (Terms of Use)

Description Nir 2005-05-10 21:25:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050509 Fedora/1.0.3-5 Firefox/1.0.3

Description of problem:
machine: fedora core 4 t2 + yum update on 10-May.

Repro:
1.
do: yum install wxPythonGTK2.i386
result: completes successfully
2.
enter python console with: python
3.
do: import wx
result: ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: _ZTV11wxFileProto

Version-Release number of selected component (if applicable):
gtk2-2.6.7-3
wxGTK2-2.4.2-9
wxPythonGTK2-2.4.2.4-5

How reproducible:
Always

Steps to Reproduce:
machine: fedora core 4 t2 + yum update on 10-May.

Repro:
1.
do: yum install wxPythonGTK2.i386
result: completes successfully
2.
enter python console with: python
3.
do: import wx
result: ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: _ZTV11wxFileProto

Actual Results:  machine: fedora core 4 t2 + yum update on 10-May.

Repro:
1.
do: yum install wxPythonGTK2.i386
result: completes successfully
2.
enter python console with: python
3.
do: import wx
result: ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: _ZTV11wxFileProto

Expected Results:  import expected to succeed

Additional info:

Comment 1 Ignacio Vazquez-Abrams 2005-05-10 22:09:36 UTC
Looks like wxPythonGTK2 needs to be rebuilt against the latest wxGTK2.

Comment 2 Michael Schwendt 2005-05-11 08:59:55 UTC
You should have wxGTK2-2.4.2-12 as released on May 9th.


Comment 3 Michael Schwendt 2005-05-11 12:01:21 UTC
Yes, wxGTK2-2.4.2-12 fixed this already. Can't reproduce (i386). A rebuild of
wxPythonGTK2 (mainly to get it also for ppc) will show up soon, though.



Note You need to log in before you can comment on or make changes to this bug.