Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157353 - inc can't get mail from local mailbox
Summary: inc can't get mail from local mailbox
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nmh
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Josh Bressers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 20:47 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 22:25:43 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2005-05-10 20:47:12 UTC
Description of problem:
inc: unable to lock and fopen /var/mail/vonbrand
Mailbox exists, and has mail. My self-build nmh-1.1 (no patches) works fine.
With this, nmh is completely useless to me.

Version-Release number of selected component (if applicable):
nmh-1.1-7.fc4

How reproducible:
Always

Steps to Reproduce:
1. inc
2.
3.
  
Actual results:
inc: unable to lock and fopen /var/mail/vonbrand

Expected results:
Get mail...

Additional info:

Comment 1 Josh Bressers 2005-05-10 21:04:10 UTC
I've verified this.  The problem is that the build is defaulting to using
dotlocks to lock files rather than filesystem locking.

I'll add a fix into CVS tonight.

Comment 2 Josh Bressers 2005-05-10 22:25:43 UTC
OK, I've fixed this in CVS.  Just waiting on the extras build process to kick
in.  In the event it takes too long, I've stuck the source rpms here:
http://people.redhat.com/bressers/nmh/


Note You need to log in before you can comment on or make changes to this bug.