Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157346 - Kudzu crashes and system hangs when setting ethernet ip address to 0.0.0.0
Summary: Kudzu crashes and system hangs when setting ethernet ip address to 0.0.0.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 19:44 UTC by Andrew Nelson
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 21:45:10 UTC


Attachments (Terms of Use)

Description Andrew Nelson 2005-05-10 19:44:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
FC3 is installed and operating correctly.  I attempt to add a dual port NIC with Intel Gigabit ports.  Upon system boot kudzu appears as expected.  Because I am unable to tell kudzu I would like to have the ethernet devices set up with no IP address I try a similar solution which works with YAST which is to set the IP addr to 0.0.0.0 and the netmask to 255.255.255.255 and the gateway and nameserver to blank.  When I proceed to the next card kudzu will either crash immediately or will crash shortly after I start to type in the same values for the second network port.

The reason for wanting to set the ethernet ports to not have an IP address is so that they can be added to an ethernet bridge later which is setup and controled by a custom application runing on the FC system.

Simple fix:
Allow users to have the interface come up without an IP address

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Shutdown installed FC3 system
2. Add dual NIC card (May also work with a single port NIC)
3. Boot
4. Wait for kudzu to appear
5. Select configure for the new ethernet device
6. enter 0.0.0.0 for the IP address and 255.255.255.255 for the netmask and leave the gateway and nameserver blank.
7. Select ok/continue
8. crash with system hang
  

Actual Results:  Crash as described in description

Expected Results:  Configuration of the ethernet device without an IP address.

Additional info:

Comment 1 Bill Nottingham 2005-05-10 21:45:10 UTC
I tested this on a box here and couldn't duplicate the error - it added the
config file with 0.0.0.0/255.255.255.255 ok (which then caused an error bringing
up the device later, but that's sort of expected.)

Considering:
a) for something like this, it's simpler to cancel out of configuring the
device, and configure it later with system-config-network
b) this dialog isn't in FC4 test releases
c) I can't reproduce it

I'm marking this as WONTFIX (although it probably could be WORKSFORME as well.)



Note You need to log in before you can comment on or make changes to this bug.