Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157321 - LVM denials
Summary: LVM denials
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 16:31 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-12 05:19:09 UTC


Attachments (Terms of Use)

Description Ivan Gyurdiev 2005-05-10 16:31:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
audit(1115741907.894:0): avc:  denied  { write } for  name=oom_adj dev=proc ino=160563227 scontext=system_u:system_r:lvm_t tcontext=system_u:system_r:lvm_t tclass=file

audit(1115741908.032:0): avc:  denied  { getattr } for  path=/var/cache/multipathd dev=dm-0 ino=1251633 scontext=system_u:system_r:lvm_t tcontext=system_u:object_r:var_t tclass=dir


Version-Release number of selected component (if applicable):
selinux-policy-strict-1.23.15-1

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:

Comment 1 Daniel Walsh 2005-05-10 17:57:49 UTC
Looks like /var/cache/multipathd needs a different context.  Some thing like

/var/cache/multipathd(/.*)? system_u:object_r:lvm_metadata_t

Will add policy to policy-1.23.15-4 to fix other problems.





Note You need to log in before you can comment on or make changes to this bug.