Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157318 - Can't install in SCSI system which doesn't boot off CDROM
Summary: Can't install in SCSI system which doesn't boot off CDROM
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 16:15 UTC by Nigel Horne
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 18:45:39 UTC


Attachments (Terms of Use)

Description Nigel Horne 2005-05-10 16:15:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
The images directory is missing drvblock.img forcing one to use FC1 which is no longer supported.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take a SCSI only machine
2. Attempt to install FC3 on it
3.
  

Actual Results:  Failed to install

Expected Results:  Should have been able to download and use drvblock.img

Additional info:

All worked fine with FC1, but FC2 and FC3 don't support this configuration.

Comment 1 Jeremy Katz 2005-05-10 19:32:16 UTC
The 2.6 kernel has grown to the point that boot floppies are no longer a
reasonable option.  Thus, the options for booting are
* CD
* USB keyfob
* Network
* Using the kernel + initrd and booting them from either another linux install
or dos (using loadlin)

Comment 2 Nigel Horne 2005-05-10 19:36:30 UTC
CD doesn't boot (see summary)
USB not available
BIOS doesn't support network boot
DOS is not on the system, but I don't understand the rest of option 4.

Is there a way of stripping out the bloatware just for initial boot?

Comment 3 Nigel Horne 2005-05-10 19:38:31 UTC
I forgot to add that I have installed FC1 which works a treat.

Can I now update to FC3, or will you start supporting FC1 again since that works
and FC3 doesn't? Or will FC4 be better?

Comment 4 Peter Jones 2005-05-16 18:45:39 UTC
Copy the kernel and initrd from the images/pxeboot/ directory on CD1 into /boot,
and add them to grub.conf .  Then select that when booting.


Note You need to log in before you can comment on or make changes to this bug.