Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157299 - smartd reports farenheit temperatures as celcius
Summary: smartd reports farenheit temperatures as celcius
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: smartmontools
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 12:24 UTC by Andy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-03 19:34:20 UTC


Attachments (Terms of Use)
Filtered 'messages' to show problem still exists (deleted)
2005-11-03 17:55 UTC, Andy
no flags Details
smartctl -a /dev/hda (deleted)
2005-11-03 17:56 UTC, Andy
no flags Details

Description Andy 2005-05-10 12:24:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
Suspect reported temperatures are in Farenheit instead of Celcius because hard drive specs for my drive specify a maximum temperature of 55°C 

/var/log/messages reports temperatures going to 107°C

If I take 107 to be Farenheit then temperature is 41°C which is more believable.

Version-Release number of selected component (if applicable):
smartd version 5.33 [i386-redhat-linux-gnu]

How reproducible:
Always

Steps to Reproduce:
1. on Fedora Core 3 Heidelberg, install the smartd rpm (clean install, no old config files)
2. start the deamon and configure a disk to be monitored by smartd
3. look at /var/log/messages 
  

Actual Results:  Temperatures reported in /var/log/messages are shown in degrees celcius

example:

May  6 16:47:52 giga smartd[3756]: Device: /dev/hda, SMART Usage Attribute: 194 Temperature_Celsius changed from 106 to 105

Expected Results:  Either the values should have been converted to Celcius, or the line should have said

May  6 16:47:52 giga smartd[3756]: Device: /dev/hda, SMART Usage Attribute: 194 Temperature_Farenheit changed from 106 to 105

Additional info:

Like said above, the readings I get are impossible if they are in Celcius.  Either the readings are false, or the readings are correct but should be converted to Celcius.

Comment 1 Tomas Mraz 2005-11-03 16:55:24 UTC
Could you please attach smartctl -a /dev/hda output here?


Comment 2 Andy 2005-11-03 17:55:13 UTC
Created attachment 120697 [details]
Filtered 'messages' to show problem still exists

This is a filtered version of the messages logfile.  I included this for
completeness

Comment 3 Andy 2005-11-03 17:56:54 UTC
Created attachment 120698 [details]
smartctl -a /dev/hda

Comment 4 Tomas Mraz 2005-11-03 19:34:20 UTC
The actual temperature in Celsius is stored in the Raw value. The value
displayed by smartd is actually a normalized value (use -r for printing the raw
value).
See also:
http://smartmontools.sourceforge.net/#FAQ


Comment 5 Andy 2005-11-03 19:38:37 UTC
Well I noticed that but as mentioned the problem is that in /var/log/messages
this temperature is considered farenheit instead of celcius

Comment 6 Tomas Mraz 2005-11-03 19:59:00 UTC
The normalized value can be just anything - for example on some disks (Maxtors)
here it is reported always as 253. The real value of the attribute is in the raw
value field and it is really Temperature_Celsius.



Note You need to log in before you can comment on or make changes to this bug.