Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157284 - evince crashes on webbench pdf
Summary: evince crashes on webbench pdf
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 06:22 UTC by Dave Jones
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 17:14:38 UTC


Attachments (Terms of Use)
webbench pdf (deleted)
2005-05-10 06:22 UTC, Dave Jones
no flags Details

Description Dave Jones 2005-05-10 06:22:13 UTC
evince webbench.pdf

This happens..


Error: Couldn't create a font for 'EHAEGK+SymbolMT'
Error: Couldn't create a font for 'EHAEGK+SymbolMT'
Error: Couldn't create a font for 'EHAEGK+SymbolMT'
Error: Couldn't create a font for 'EHAEGK+SymbolMT'
Error: Couldn't create a font for 'EHAEJO+Wingdings-Regular'
Error: Couldn't create temporary font file
*** glibc detected *** evince: corrupted double-linked list: 0x00002aaaae40d440 ***
======= Backtrace: =========
/lib64/libc.so.6[0x35d586a310]
/lib64/libc.so.6[0x35d586a7b8]
/lib64/libc.so.6(__libc_free+0x6e)[0x35d586ad5e]
/usr/lib64/libpoppler.so.0(_ZN11FlateStream10startBlockEv+0x2c)[0x35dddb4572]
/usr/lib64/libpoppler.so.0(_ZN11FlateStream8readSomeEv+0x76)[0x35dddb475a]
/usr/lib64/libpoppler.so.0(_ZN11FlateStream8lookCharEv+0x25)[0x35dddb499f]
/usr/lib64/libpoppler.so.0(_ZN5Lexer6getObjEP6Object+0xd1)[0x35ddda844b]
/usr/lib64/libpoppler.so.0(_ZN6Parser6getObjEP6ObjectPhiii+0x6c)[0x35dddafd74]
/usr/lib64/libpoppler.so.0(_ZN3Gfx2goEi+0xe1)[0x35ddd779cd]
/usr/lib64/libpoppler.so.0(_ZN3Gfx7displayEP6Objecti+0x9b)[0x35ddd783b9]
/usr/lib64/libpoppler.so.0(_ZN4Page12displaySliceEP9OutputDevddiiiiiiP5LinksP7CatalogPFiPvES6_PFiP5AnnotS6_ES6_+0x25f)[0x35dddaf4d5]
/usr/lib64/libpoppler-glib.so.0(poppler_page_render_to_pixbuf+0x134)[0x35dd905eae]
evince[0x42492f]
evince(ev_job_thumbnail_run+0x78)[0x429967]
evince[0x428b22]
/usr/lib64/libglib-2.0.so.0[0x35d633e4da]
/lib64/libpthread.so.0[0x35d710697c]
/lib64/libc.so.6(__clone+0x6e)[0x35d58c995e]
======= Memory map: ========
00400000-0043a000 r-xp 00000000 fd:00 18756553                          
/usr/bin/evince
0053a000-00543000 rw-p 0003a000 fd:00 18756553                          
/usr/bin/evince
00543000-00d19000 rw-p 00543000 00:00 0                                  [heap]
40000000-40001000 ---p 40000000 00:00 0
40001000-40a01000 rw-p 40001000 00:00 0
35d5600000-35d561a000 r-xp 00000000 fd:00 2359527                       
/lib64/ld-2.3.5.so
35d5719000-35d571a000 r--p 00019000 fd:00 2359527                       
/lib64/ld-2.3.5.so
35d571a000-35d571b000 rw-p 0001a000 fd:00 2359527                       
/lib64/ld-2.3.5.so
35d5800000-35d592d000 r-xp 00000000 fd:00 2359528                       
/lib64/libc-2.3.5.so
35d592d000-35d5a2c000 ---p 0012d000 fd:00 2359528                       
/lib64/libc-2.3.5.so
35d5a2c000-35d5a30000 r--p 0012c000 fd:00 2359528                       
/lib64/libc-2.3.5.so
35d5a30000-35d5a32000 rw-p 00130000 fd:00 2359528                       
/lib64/libc-2.3.5.so
35d5a32000-35d5a36000 rw-p 35d5a32000 00:00 0
35d5b00000-35d5b83000 r-xp 00000000 fd:00 2359531                       
/lib64/libm-2.3.5.so
35d5b83000-35d5c83000 ---p 00083000 fd:00 2359531                       
/lib64/libm-2.3.5.so
35d5c83000-35d5c84000 r--p 00083000 fd:00 2359531                       
/lib64/libm-2.3.5.so
35d5c84000-35d5c85000 rw-p 00084000 fd:00 2359531                       
/lib64/libm-2.3.5.so
35d5d00000-35d5d02000 r-xp 00000000 fd:00 2359532                       
/lib64/libdl-2.3.5.so
35d5d02000-35d5e02000 ---p 00002000 fd:00 2359532                       
/lib64/libdl-2.3.5.so
35d5e02000-35d5e03000 r--p 00002000 fd:00 2359532                       
/lib64/libdl-2.3.5.so
35d5e03000-35d5e04000 rw-p 00003000 fd:00 2359532                       
/lib64/libdl-2.3.5.so
35d5f00000-35d5f14000 r-xp 00000000 fd:00 18761507                      
/usr/lib64/libz.so.1.2.2.2
35d5f14000-35d6013000 ---p 00014000 fd:00 18761507                      
/usr/lib64/libz.so.1.2.2.2
35d6013000-35d6014000 rw-p 00013000 fd:00 18761507                      
/usr/lib64/libz.so.1.2.2.2
35d6100000-35d61da000 r-xp 00000000 fd:00 18765427                      
/usr/X11R6/lib64/libX11.so.6.2
35d61da000-35d62d9000 ---p 000da000 fd:00 18765427                      
/usr/X11R6/lib64/libX11.so.6.2
35d62d9000-35d62df000 rw-p 000d9000 fd:00 18765427                      
/usr/X11R6/lib64/libX11.so.6.2
35d6300000-35d6384000 r-xp 00000000 fd:00 18759231                      
/usr/lib64/libglib-2.0.so.0.600.4
35d6384000-35d6483000 ---p 00084000 fd:00 18759231                      
/usr/lib64/libglib-2.0.so.0.600.4
35d6483000-35d6489000 rw-p 00083000 fd:00 18759231                      
/usr/lib64/libglib-2.0.so.0.600.4
35d6489000-35d648a000 rw-p 35d6489000 00:00 0
35d6500000-35d6510000 r-xp 00000000 fd:00 18765428                      
/usr/X11R6/lib64/libXext.so.6.4
35d6510000-35d6610000 ---p 00010000 fd:00 18765428                      
/usr/X11R6/lib64/libXext.so.6.4
35d6610000-35d6611000 rw-p 00010000 fd:00 18765428                      
/usr/X11R6/lib64/libXext.so.6.4
35d6700000-35d6737000 r-xp 00000000 fd:00 18765451                      
/usr/lib64/libgobject-2.0.so.0.600.4
35d6737000-35d6837000 ---p 00037000 fd:00 18765451                      
/usr/lib64/libgobject-2.0.so.0.600.4
35d6837000-35d683c000 rw-p 00037000 fd:00 18765451                      
/usr/lib64/libgobject-2.0.so.0.600.4
35d6900000-35d6921000 r-xp 00000000 fd:00 18765434                      
/usr/lib64/libexpat.so.0.5.0
35d6921000-35d6a20000 ---p 00021000 fd:00 18765434                      
/usr/lib64/libexpat.so.0.5.0
35d6a20000-35d6a23000 rw-p 00020000 fd:00 18765434                      
/usr/lib64/libexpat.so.0.5.0
35d6b00000-35d6b03000 r-xp 00000000 fd:00 18765452                      
/usr/lib64/libgmodule-2.0.so.0.600.4
35d6b03000-35d6c02000 ---p 00003000 fd:00 18765452                      
/usr/lib64/libgmodule-2.0.so.0.600.4
35d6c02000-35d6c03000 rw-p 00002000 fd:00 18765452                      
/usr/lib64/libgmodule-2.0.so.0.600.4
35d6d00000-35d6d7f000 r-xp 00000000 fd:00 18765433                      
/usr/lib64/libfreetype.so.6.3.7
35d6d7f000-35d6e7f000 ---p 0007f000 fd:00 18765433                      
/usr/lib64/libfreetype.so.6.3.7
35d6e7f000-35d6e8c000 rw-p 0007f000 fd:00 18765433                      
/usr/lib64/libfreetype.so.6.3.7
35d6f00000-35d6f2c000 r-xp 00000000 fd:00 18765435                      
/usr/lib64/libfontconfig.so.1.0.4
35d6f2c000-35d702c000 ---p 0002c000 fd:00 18765435                      
/usr/lib64/libfontconfig.so.1.0.4
35d702c000-35d7031000 rw-p 0002c000 fd:00 18765435                      
/usr/lib64/libfontconfig.so.1.0.4
35d7031000-35d7033000 rw-p 35d7031000 00:00 0
35d7100000-35d710f000 r-xp 00000000 fd:00 2359529                       
/lib64/libpthread-2.3.5.so
35d710f000-35d720f000 ---p 0000f000 fd:00 2359529                       
/lib64/libpthread-2.3.5.so
35d720f000-35d7210000 r--p 0000f000 fd:00 2359529                       
/lib64/libpthread-2.3.5.so
35d7210000-35d7211000 rw-p 00010000 fd:00 2359529                       
/lib64/libpthread-2.3.5.so
35d7211000-35d7215000 rw-p 35d7211000 00:00 0
35d7300000-35d7308000 r-xp 00000000 fd:00 18765429                      
/usr/X11R6/lib64/libXrender.so.1.2.2
35d7308000-35d7408000 ---p 00008000 fd:00 18765429                      
/usr/X11R6/lib64/libXrender.so.1.2.2
35d7408000-35d7409000 rw-p 00008000 fd:00 18765429                      
/usr/X11R6/lib64/libXrender.so.1.2.2
35d7500000-35d7514000 r-xp 00000000 fd:00 18765436                      
/usr/X11R6/lib64/libXft.so.2.1.2
35d7514000-35d7613000 ---p 00014000 fd:00 18765436                      
/usr/X11R6/lib64/libXft.so.2.1.2
35d7613000-35d7614000 rw-p 00013000 fd:00 18765436                      
/usr/X11R6/lib64/libXft.so.2.1.2
35d7700000-35d7702000 r-xp 00000000 fd:00 18765432                      
/usr/X11R6/lib64/libXinerama.so.1.0
35d7702000-35d7801000 ---p 00002000 fd:00 18765432                      
/usr/X11R6/lib64/libXinerama.so.1.0
35d7801000-35d7802000 rw-p 00001000 fd:00 18765432                      
/usr/X11R6/lib64/libXinerama.so.1.0
35d7900000-35d7903000 r-xp 00000000 fd:00 18765430                      
/usr/X11R6/lib64/libXrandr.so.2.0
35d7903000-35d7a02000 ---p 00003000 fd:00 18765430                      
/usr/X11R6/lib64/libXrandr.so.2.0
35d7a02000-35d7a03000 rw-p 00002000 fd:00 18765430                      
/usr/X11R6/lib64/libXrandr.so.2.0
35d7b00000-35d7b09000 r-xp 00000000 fd:00 18765431                      
/usr/X11R6/lib64/libXcursor.so.1.0.2
35d7b09000-35d7c09000 ---p 00009000 fd:00 18765431                      
/usr/X11R6/lib64/libXcursor.so.1.0.2
35d7c09000-35d7c0a000 rw-p 00009000 fd:00 18765431                      
/usr/X11R6/lib64/libXcursor.so.1.0.2
35d7d00000-35d7d28000 r-xp 00000000 fd:00 18765454                      
/usr/lib64/libpangoft2-1.0.so.0.800.1
35d7d28000-35d7e28000 ---p 00028000 fd:00 18765454                      
/usr/lib64/libpangoft2-1.0.so.0.800.1
35d7e28000-35d7e2a000 rw-p 00028000 fd:00 18765454                      
/usr/lib64/libpangoft2-1.0.so.0.800.1
35d7f00000-35d7f07000 r-xp 00000000 fd:00 18765459                      
/usr/lib64/libpangoxft-1.0.so.0.800.1
35d7f07000-35d8006000 ---p 00007000 fd:00 18765459                      
/usr/lib64/libpangoxft-1.0.so.0.800.1
35d8006000-35d8007000 rw-p 00006000 fd:00 18765459                      
/usr/lib64/libpangoxft-1.0.so.0.800.1
35d8100000-35d811a000 r-xp 00000000 fd:00 18765462                      
/usr/lib64/libatk-1.0.so.0.901.0
35d811a000-35d8219000 ---p 0001a000 fd:00 18765462                      
/usr/lib64/libatk-1.0.so.0.901.0
35d8219000-35d821e000 rw-p 00019000 fd:00 18765462                      
/usr/lib64/libatk-1.0.so.0.901.0
35d8300000-35d8314000 r-xp 00000000 fd:00 18757504                      
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
35d8314000-35d8414000 ---p 00014000 fd:00 18757504                      
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
35d8414000-35d8416000 rw-p 00014000 fd:00 18757504                      
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
35d8500000-35d8508000 r-xp 00000000 fd:00 18765457                      
/usr/X11R6/lib64/libXi.so.6.0
35d8508000-35d8607000 ---p 00008000 fd:00 18765457                      
/usr/X11R6/lib64/libXi.so.6.0
35d8607000-35d8608000 rw-p 00007000 fd:00 18765457                      
/usr/X11R6/lib64/libXi.so.6.0
35d8700000-35d873b000 r-xp 00000000 fd:00 18765453                      
/usr/lib64/libpango-1.0.so.0.800.1
35d873b000-35d883b000 ---p 0003b000 fd:00 18765453                      
/usr/lib64/libpango-1.0.so.0.800.1
35d883b000-35d8844000 rw-p 0003b000 fd:00 18765453                      
/usr/lib64/libpango-1.0.so.0.800.1
35d8900000-35d8980000 r-xp 00000000 fd:00 18765461                      
/usr/lib64/libgdk-x11-2.0.so.0.600.7
35d8980000-35d8a7f000 ---p 00080000 fd:00 18765461                      
/usr/lib64/libgdk-x11-2.0.so.0.600.7
35d8a7f000-35d8a89000 rw-p 0007f000 fd:00 18765461                      
/usr/lib64/libgdk-x11-2.0.so.0.600.7
35d8b00000-35d8b0b000 r-xp 00000000 fd:00 18765460                      
/usr/lib64/libpangox-1.0.so.0.800.1
35d8b0b000-35d8c0b000 ---p 0000b000 fd:00 18765460                      
/usr/lib64/libpangox-1.0.so.0.800.1
35d8c0b000-35d8c0c000 rw-p 0000b000 fd:00 18765460                      
/usr/lib64/libpangox-1.0.so.0.800.1
35d8d00000-35d8fad000 r-xp 00000000 fd:00 18765463                      
/usr/lib64/libgtk-x11-2.0.so.0.600.7
35d8fad000-35d90ac000 ---p 002ad000 fd:00 18765463                      
/usr/lib64/libgtk-x11-2.0.so.0.600.7
35d90ac000-35d90dd000 rw-p 002ac000 fd:00 18765463                      
/usr/lib64/libgtk-x11-2.0.so.0.600.7
35d90dd000-35d90e0000 rw-p 35d90dd000 00:00 0
35d9100000-35d9105000 r-xp 00000000 fd:00 18765458                      
/usr/X11R6/lib64/libXfixes.so.3.0
35d9105000-35d9204000 ---p 00005000 fd:00 18765458                      
/usr/X11R6/lib64/libXfixes.so.3.0
35d9204000-35d9205000 rw-p 00004000 fd:00 18765458                      
/usr/X11R6/lib64/libXfixes.so.3.0
35d9300000-35d9307000 r-xp 00000000 fd:00 18759036                       /usr/

It then hangs.  Oddly, ctrl-c, and retry, and the pdf loads just fine, with no
warnings.

nautilus also seems to repeatedly segfault whilst trying to thumbnail this pdf.

Comment 1 Dave Jones 2005-05-10 06:22:14 UTC
Created attachment 114192 [details]
webbench pdf

Comment 2 Marco Pesenti Gritti 2005-05-10 07:56:49 UTC
I cannot reproduce this on 0.3.1

Comment 3 Kristian Høgsberg 2005-05-10 19:14:35 UTC
I tested this with evince.i386 0:0.2.1-1 and  poppler.i386 0:0.3.0-2 and could
not reproduce the problem either.


Comment 4 Dave Jones 2005-05-10 23:00:45 UTC
I have 0.2.1-1 here. Is 0.3.1 ending up in rawhide anytime soon?

Comment 5 Marius Andreiana 2005-05-31 17:14:38 UTC
Dave, please test again with current rawhide. Seems poppler updates fixed this.
Please reopen if still doesn't work for you.

However, the attached pdf displays gibberish. Quote 
"In general, we found that Windows Server 2003 provided better overall peak Web
serving compared to both Red Hat Linux Advanced Server 2.1 and Red Hat Linux 8.0
Professional"
But for this you need to file a bug on ethics.microsoft.com :-)


Note You need to log in before you can comment on or make changes to this bug.