Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157276 - installing kernel headers - catch 22
Summary: installing kernel headers - catch 22
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 03:03 UTC by Sakshale eQuorian
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 22:58:20 UTC


Attachments (Terms of Use)

Description Sakshale eQuorian 2005-05-10 03:03:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
I did a "minimal install" because of some dependancy problems with the full install on my x86_64 system.  When I went to install GCC, it required glibc-headers.  However, glibc-headers requires kernel headers. So, I downloaded the source for the kernel, kernel-2.6.9-1.667.src.rpm and installed it.  According to the docs I've found, the next step is supposed to be "rpmbuild -bp --target=noarch /usr/src/redhat/SPECS/kernel-2.6.spec". It fails because GCC is not installed.  So, I am in a catch 22 situation.  I can't install GCC without the kernel headers and I can't install the kernel headers without GCC.

Version-Release number of selected component (if applicable):
kernel source install requires gcc - gcc requires kernel headers

How reproducible:
Always

Steps to Reproduce:
1. perform a minimal install
2. try to install GCC from the FC3 rpm collection
3. try to install kernel headers from the RC# srpm collection
  

Actual Results:  cross dependancy failure

Expected Results:  bring back the separate kernel-headers rpm

Additional info:

I'm hoping someone will say, "Hay dummy! All you need to do is.... " :)

Comment 1 Dave Jones 2005-05-10 22:58:20 UTC
gcc wants glibc-kernheaders, not the kernel source.


Comment 2 Dave Jones 2005-05-10 22:58:57 UTC
sorry, that should be _glibc_ wants glibc-kernheaders, not the kernel source.

Comment 3 Sakshale eQuorian 2005-05-12 00:11:31 UTC
Excellent - That was all I needed to know.  Thank you.


Note You need to log in before you can comment on or make changes to this bug.