Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157275 - Kernel BUG at spinlock:121
Summary: Kernel BUG at spinlock:121
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-10 02:42 UTC by Philippe Rigault
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-04 07:10:46 UTC


Attachments (Terms of Use)

Description Philippe Rigault 2005-05-10 02:42:40 UTC
Description of problem: 
Error message:  
Kernel BUG at spinlock:121  
invalid operand: 0000 [1] SMP  
  
Version-Release number of selected component (if applicable):  
kernel-smp-2.6.11-1.14_FC3.x86_64  
  
How reproducible:  
Happened once  
  
Additional info:  
info in /var/log/messages:  
<snip>  
May  9 22:23:43 mybox kernel: eip: ffffffff80283dd4  
May  9 22:23:43 mybox kernel: ----------- [cut here ] --------- [please bite  
here ] ---------  
May  9 22:23:43 mybox kernel: Kernel BUG at spinlock:121  
May  9 22:23:43 mybox kernel: invalid operand: 0000 [1] SMP  
May  9 22:23:43 mybox kernel: CPU 1  
May  9 22:23:43 mybox kernel: Modules linked in: vfat fat usb_storage  
parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc ipt_LOG ipt_limit md5  
ipv6 ipt_MASQUERADE iptable_nat ppp_synctty ppp_async crc_ccitt ppp_generic  
slhc pcmcia yenta_socket rsrc_nonstatic pcmcia_core ipt_REJECT ipt_state  
ip_conntrack iptable_filter ip_tables xfs exportfs dm_mod video button battery  
ac usblp ohci1394 ieee1394 ohci_hcd ehci_hcd snd_emu10k1 snd_rawmidi  
snd_seq_device snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer  
snd_page_alloc snd_util_mem snd_hwdep snd soundcore e100 mii tg3 floppy ext3  
jbd 3w_xxxx sd_mod scsi_mod  
May  9 22:23:43 mybox kernel: Pid: 20543, comm: gam_server Not tainted  
2.6.11-1.14_FC3smp  
May  9 22:23:43 mybox kernel: RIP: 0010:[<ffffffff80347ea0>]  
<ffffffff80347ea0>{_spin_lock+32}  
May  9 22:23:43 mybox kernel: RSP: 0018:ffff8100737e9d18  EFLAGS: 00010092  
May  9 22:23:43 mybox kernel: RAX: 0000000000000016 RBX: ffff8100418ba834 RCX:  
ffffffff80417f08  
May  9 22:23:43 mybox kernel: RDX: ffffffff80417f08 RSI: 0000000000000082 RDI:  
ffffffff80417f00  
May  9 22:23:43 mybox kernel: RBP: ffff81007f562000 R08: ffff8100e200a040 R09:  
000000000000000f  
May  9 22:23:43 mybox kernel: R10: 0000000000000000 R11: 0000000000000064 R12:  
ffff8100e2dae0d0  
May  9 22:23:43 mybox kernel: R13: ffff8100e2dae0e8 R14: ffff8100e25b26c8 R15:  
0000000000000282  
May  9 22:23:43 mybox kernel: FS:  00002aaaaafa96e0(0000) GS:ffffffff804e8a00 
(0000) knlGS:0000000057a7a720  
May  9 22:23:43 mybox kernel: CS:  0010 DS: 0000 ES: 0000 CR0:  
000000008005003b  
May  9 22:23:43 mybox kernel: CR2: 000000000057bbf0 CR3: 0000000078704000 CR4:  
00000000000006e0  
May  9 22:23:43 mybox kernel: Process gam_server (pid: 20543, threadinfo  
ffff8100737e8000, task ffff8100de00c070)  
May  9 22:23:43 mybox kernel: Stack: ffff8100e2dacca0 ffffffff80283dd4  
0000000000000082 ffff8100e2dacca0  
May  9 22:23:43 mybox kernel:        0000000000000006 ffff8100de00c070  
0000000000000006 0000000000000000  
May  9 22:23:43 mybox kernel:        ffff8100737e9ef8 ffffffff8027bd3d  
May  9 22:23:43 mybox kernel: Call  
Trace:<ffffffff80283dd4>{cfq_exit_io_context+164}  
<ffffffff8027bd3d>{exit_io_context+93}  
May  9 22:23:43 mybox kernel:        <ffffffff8013acc5>{do_exit+117}  
<ffffffff801436d5>{__dequeue_signal+485}  
May  9 22:23:43 mybox kernel:        <ffffffff8013b8ff>{do_group_exit+239}  
<ffffffff801457da>{get_signal_to_deliver+1514}  
May  9 22:23:43 mybox kernel:        <ffffffff8010d963>{do_signal+163}  
<ffffffff801b817e>{dnotify_parent+46}  
May  9 22:23:43 mybox kernel:        <ffffffff8010e3ca>{sys_rt_sigreturn+682}  
<ffffffff8014593d>{sigprocmask+253}  
May  9 22:23:43 mybox kernel:        <ffffffff801459d3>{sys_rt_sigprocmask+99}  
<ffffffff8010e3ca>{sys_rt_sigreturn+682}  
May  9 22:23:43 mybox kernel:        <ffffffff8010e5a3>{sysret_signal+28}  
<ffffffff8010e88f>{ptregscall_common+103}  
May  9 22:23:43 mybox kernel:  
May  9 22:23:43 mybox kernel:  
May  9 22:23:43 mybox kernel: Code: 0f 0b 77 83 36 80 ff ff ff ff 79 00 f0 fe  
0b 0f 88 b2 04 00  
May  9 22:23:43 mybox kernel: RIP <ffffffff80347ea0>{_spin_lock+32} RSP  
<ffff8100737e9d18>  
<snip>  
May  9 22:28:01 mybox init: Switching to runlevel: 6  
May  9 22:28:02 mybox cups-config-daemon: cups-config-daemon -TERM succeeded  
May  9 22:28:02 mybox haldaemon: haldaemon -TERM succeeded  
May  9 22:28:02 mybox messagebus: messagebus -TERM succeeded  
May  9 22:28:02 mybox atd: atd shutdown succeeded  
May  9 22:28:02 mybox cups: cupsd shutdown succeeded  
May  9 22:28:02 mybox xfs[4124]: terminating  
May  9 22:28:02 mybox xfs: xfs shutdown succeeded  
May  9 22:28:03 mybox gpm: gpm shutdown succeeded  
May  9 22:28:03 mybox sshd: sshd -TERM succeeded  
May  9 22:28:03 mybox xinetd[4066]: Exiting...  
May  9 22:28:03 mybox xinetd: xinetd shutdown succeeded  
May  9 22:28:03 mybox kernel:  eip: ffffffff80283d9e  
May  9 22:28:03 mybox kernel: ----------- [cut here ] --------- [please bite  
here ] ---------  
May  9 22:28:03 mybox kernel: Kernel BUG at spinlock:121  
May  9 22:28:03 mybox kernel: invalid operand: 0000 [2] SMP  
May  9 22:28:03 mybox kernel: CPU 0  
May  9 22:28:03 mybox kernel: Modules linked in: vfat fat usb_storage  
parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc ipt_LOG  
 ipt_limit md5 ipv6 ipt_MASQUERADE iptable_nat ppp_synctty ppp_async crc_ccitt  
ppp_generic slhc pcmcia yenta_socket rsrc_nonstatic  
pcmcia_core ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables xfs  
exportfs dm_mod video button battery ac usblp ohci1394 i  
eee1394 ohci_hcd ehci_hcd snd_emu10k1 snd_rawmidi snd_seq_device  
snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_pag  
e_alloc snd_util_mem snd_hwdep snd soundcore e100 mii tg3 floppy ext3 jbd  
3w_xxxx sd_mod scsi_mod  
May  9 22:28:03 mybox kernel: Pid: 4186, comm: hald Not tainted  
2.6.11-1.14_FC3smp  
May  9 22:28:03 mybox kernel: RIP: 0010:[<ffffffff80347ea0>]  
<ffffffff80347ea0>{_spin_lock+32}  
May  9 22:28:03 mybox kernel: RSP: 0018:ffff81007de6fe98  EFLAGS: 00010096  
May  9 22:28:03 mybox kernel: RAX: 0000000000000016 RBX: ffff8100418ba834 RCX:  
ffffffff80417f08  
May  9 22:28:03 mybox kernel: RDX: ffffffff80417f08 RSI: 0000000000000086 RDI:  
ffffffff80417f00  
May  9 22:28:03 mybox kernel: RBP: ffff81007f562000 R08: ffff8100e200a040 R09:  
000000000000000f  
May  9 22:28:03 mybox kernel: R10: 0000000000000000 R11: ffffffff80211910 R12:  
ffff8100e2dae5e0  
May  9 22:28:03 mybox kernel: R13: ffff8100e2dae5f8 R14: ffff81007f0b43c8 R15:  
0000000000000286  
May  9 22:28:03 mybox kernel: FS:  00002aaaaba0c180(0000) GS:ffffffff804e8980 
(0000) knlGS:0000000059cc9bb0  
May  9 22:28:03 mybox kernel: CS:  0010 DS: 0000 ES: 0000 CR0:  
000000008005003b  
May  9 22:28:03 mybox kernel: CR2: 00002aaaab8ee728 CR3: 000000007de1d000 CR4:  
00000000000006e0  
May  9 22:28:03 mybox kernel: Process hald (pid: 4186, threadinfo  
ffff81007de6e000, task ffff8100de00c790)  
May  9 22:28:03 mybox kernel: Stack: ffff8100e2daec70 ffffffff80283d9e  
ffff81007de6fed8 ffff8100e2dac5e0  
May  9 22:28:03 mybox kernel:        0000000000000000 ffff8100de00c790  
0000000000000000 0000000000405288  
May  9 22:28:03 mybox kernel:        00007ffffffff730 ffffffff8027bd3d  
May  9 22:28:03 mybox kernel: Call  
Trace:<ffffffff80283d9e>{cfq_exit_io_context+110}  
<ffffffff8027bd3d>{exit_io_context+93}  
May  9 22:28:03 mybox kernel:        <ffffffff8013acc5>{do_exit+117}  
<ffffffff80180e9c>{vfs_read+268}  
May  9 22:28:03 mybox kernel:        <ffffffff8013b8ff>{do_group_exit+239}  
<ffffffff8010e51a>{system_call+126}  
May  9 22:28:03 mybox kernel:  
May  9 22:28:03 mybox kernel:  
May  9 22:28:03 mybox kernel: Code: 0f 0b 77 83 36 80 ff ff ff ff 79 00 f0 fe  
0b 0f 88 b2 04 00  
May  9 22:28:03 mybox kernel: RIP <ffffffff80347ea0>{_spin_lock+32} RSP  
<ffff81007de6fe98>  
May  9 22:28:03 mybox acpid: acpid shutdown succeeded  
May  9 22:28:03 mybox crond: crond shutdown succeeded  
May  9 22:28:03 mybox mDNSResponder: mDNSResponder shutdown succeeded  
May  9 22:28:03 mybox nifd: nifd shutdown succeeded  
May  9 22:28:03 mybox nfslock: lockd shutdown failed  
May  9 22:28:03 mybox rpc.statd[3760]: Caught signal 15, un-registering and  
exiting.  
May  9 22:28:04 mybox nfslock: rpc.statd shutdown succeeded  
May  9 22:28:04 mybox portmap: portmap shutdown succeeded  
May  9 22:28:04 mybox kernel: Kernel logging (proc) stopped.  
May  9 22:28:04 mybox kernel: Kernel log daemon terminating.  
May  9 22:28:05 mybox syslog: klogd shutdown succeeded  
May  9 22:28:05 mybox exiting on signal 15  
May  9 22:29:51 mybox syslogd 1.4.1: restart.  
<snip>

Comment 1 Dave Jones 2005-05-10 22:54:56 UTC
Please try the kernel in updates-testing, (or better yet, the latest one from
http://people.redhat.com/davej/kernels/Fedora/FC3/ )

I think this is a dupe of several other bugs that got reported.
First time it hit on amd64 though.

Comment 2 Dave Jones 2005-06-04 07:10:46 UTC

*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.