Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157274 - Unable to merge header list:
Summary: Unable to merge header list:
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-10 02:33 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-03 18:01:42 UTC


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-05-10 02:33:32 UTC
Description of problem:

Install shows:

Unable to merge header list. This may be due to missing file or bad media. Press
<enter> to try again.

Install console shows:

IOError 28 occurred getting http://192.168.11./rawhide/Fedora/base/hdlist2: No
space left on device

df shows:

both /mnt/runtime and /mnt/sysimage (this last one is where hdlist2 is located)
as 100% in use.

Version-Release number of selected component (if applicable):

10.2.0.61

How reproducible:

always

Steps to Reproduce:
1. boot rawhide install 
2.
3.
  
Actual results:

error message

Expected results:

install completes normally

Additional info:

hdlist2 on my system shows 25001916
the one in sysimage is     14659584

My system has 192MB of RAM.

Comment 1 Jeremy Katz 2005-05-19 00:57:12 UTC
I'm not reproducing this with today's rawhide... can you try again?

Comment 2 Ricky Ng-Adam 2005-05-19 02:33:06 UTC
Same problem with anaconda-10.2.0.63. Did you mean something more recent?

I forgot to mention that I'm testing by PXE Boot / network install.

Comment 3 Jeremy Katz 2005-05-19 19:00:45 UTC
Bumped the amount of RAM we require for the graphical stage2.  It's working for
me, but it's clearly sort of at the border for working.

Comment 4 Ricky Ng-Adam 2005-05-20 23:42:09 UTC
Are you saying that from now on, it will not be possible to use the
install on this computer even when graphical install for FC4 was working ok up
to 10.2.0.61? 

Is this something that is going to be fixed or something that will
never work again?

And when you say bumped up the amount of RAM, do you mean in a check in
anaconda?  Because anaconda-10.2.0.64-1.i386.rpm still gives the same error,
both in graphical and text install.

Why exactly is it not working anymore? Is it because hdlist2 has gotten too big?


Note You need to log in before you can comment on or make changes to this bug.