Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157249 - Error setting AP with "(" and ")" char
Summary: Error setting AP with "(" and ")" char
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 19:54 UTC by Orhan Sancaktar
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 21:46:52 UTC


Attachments (Terms of Use)

Description Orhan Sancaktar 2005-05-09 19:54:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Some of our local coffe shops use a wireless service that has its ESSID Set to "Internet Oasis (FREE)".  When I try to associate with the network, the program give the error "invalid character in key/directory names".  This must be a valid character b/c i can connect manually without any problems using iwconfig.

Version-Release number of selected component (if applicable):
NetworkManager-0.3.1-3

How reproducible:
Always

Steps to Reproduce:
1. Run NetworkManager and NetworkManagerInfo
2. Select "InternetOasis (FREE)" network
3.
  

Actual Results:  Bad key or directory name: "/system/networking/wireless/networks/Internet Oasis (FREE)/timestamp": ` ' is an invalid character in key/directory names
Bad key or directory name: "/system/networking/wireless/networks/Internet Oasis (FREE)/essid": ` ' is an invalid character in key/directory names


Expected Results:  Associate with the AP and obtain a DHCP lease.

Additional info:

Comment 1 Dan Williams 2005-05-09 19:58:23 UTC
Is there any way you can test NetworkManager-0.3.4-1.1.0.fc3, which has been in
FC3-updates for a while?  I believe that's fixed this problem and it should
escape GConf keys correctly.

A 'yum update NetworkManager' should install that version, otherwise look at:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/



Comment 2 Orhan Sancaktar 2005-05-09 20:54:46 UTC
Same error with NetworkManager-0.3.4-1.1.0.fc3.

Sorry about not updating before asking.

Comment 3 Orhan Sancaktar 2005-05-09 21:46:52 UTC
Now it seems to be working...


Note You need to log in before you can comment on or make changes to this bug.