Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157247 - bonding module with sk98lin module generates a huge amount of kernel messages
Summary: bonding module with sk98lin module generates a huge amount of kernel messages
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 19:33 UTC by Stephen Mah
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 19:59:38 UTC


Attachments (Terms of Use)

Description Stephen Mah 2005-05-09 19:33:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041118 Firefox/1.0

Description of problem:
The /var/log/messages file gets filled with the following kernel messages:
May  9 12:26:27 gds1 kernel:  [<f89b2e2d>] bond_mii_monitor+0x313/0x3b7 [bonding]
May  9 12:26:27 gds1 kernel:  [<f89b2b1a>] bond_mii_monitor+0x0/0x3b7 [bonding]
May  9 12:26:27 gds1 kernel:  [<c0128357>] run_timer_softirq+0x123/0x145
May  9 12:26:27 gds1 kernel:  [<c0124aa4>] __do_softirq+0x4c/0xb1
May  9 12:26:27 gds1 kernel:  [<c0107f39>] do_softirq+0x4f/0x56
May  9 12:26:27 gds1 kernel:  =======================
May  9 12:26:27 gds1 kernel:  [<c011633f>] smp_apic_timer_interrupt+0xd9/0xdd
May  9 12:26:27 gds1 kernel:  [<c02c6e3a>] apic_timer_interrupt+0x1a/0x20
May  9 12:26:27 gds1 kernel:  [<c01040e5>] mwait_idle+0x33/0x42
May  9 12:26:27 gds1 kernel:  [<c010409d>] cpu_idle+0x26/0x3b
May  9 12:26:27 gds1 kernel:  [<c0382784>] start_kernel+0x194/0x198
May  9 12:26:28 gds1 kernel: Debug: sleeping function called from invalid context at include/asm/uaccess.h:556
May  9 12:26:28 gds1 kernel: in_atomic():1[expected: 0], irqs_disabled():0
May  9 12:26:28 gds1 kernel:  [<c011e5ce>] __might_sleep+0x7d/0x87
May  9 12:26:28 gds1 kernel:  [<f8a0e430>] SkGeIoctl+0x3d/0x44d [sk98lin]
May  9 12:26:28 gds1 kernel:  [<c011b529>] activate_task+0x88/0x95
May  9 12:26:28 gds1 kernel:  [<f89b162f>] bond_update_speed_duplex+0x96/0xda [bonding]
May  9 12:26:28 gds1 kernel:  [<c011b496>] recalc_task_prio+0x128/0x133
May  9 12:26:28 gds1 kernel:  [<c011b529>] activate_task+0x88/0x95
May  9 12:26:28 gds1 kernel:  [<c011b9ad>] try_to_wake_up+0x225/0x230
May  9 12:26:28 gds1 kernel:  [<c0129a7d>] __group_send_sig_info+0x8f/0x98
May  9 12:26:28 gds1 kernel:  [<f89b2e2d>] bond_mii_monitor+0x313/0x3b7 [bonding]
May  9 12:26:28 gds1 kernel:  [<f89b2b1a>] bond_mii_monitor+0x0/0x3b7 [bonding]
May  9 12:26:28 gds1 kernel:  [<c0128357>] run_timer_softirq+0x123/0x145
May  9 12:26:28 gds1 kernel:  [<c0124aa4>] __do_softirq+0x4c/0xb1
May  9 12:26:28 gds1 kernel:  [<c0107f39>] do_softirq+0x4f/0x56




Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.5.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Configure bonding with atleast two sk98lin nic cards.
2. use bonding mode=5
3. ifup bond0
  

Actual Results:  /var/log/messages gets full of kernel messages. Non-stop messages at the console.

Expected Results:  minimal kernel messages

Additional info:

ethtool does not seem to work on the sk98lin module:
ethtool:
Running ethtool on the 3com syskonnect does not work:
ethtool eth0 (eth0 is using the sk98lin modules provided by the RHEL4 kernel)
Settings for eth0:
No data available

Running ethtool on the broadcom Tigon card seems to work

Comment 1 John W. Linville 2005-05-11 19:59:38 UTC
It looks like the sk98lin driver does not support either miitool or ethtool 
(or their supporting ioctls).  Passing the "use_carrier=1" option to the 
bonding module might work, except that the sk98lin driver also fails to 
properly use netif_carrier_{on|off} to set the link state flags.  So, I don't 
think there is any way to make miimon work w/ sk98lin slaves.  I would advise 
using arpmon with the bonding module instead. 
 


Note You need to log in before you can comment on or make changes to this bug.