Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157226 - Evolution Exchange support does not work
Summary: Evolution Exchange support does not work
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution-connector
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 16:11 UTC by Chris Lee
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-14 19:50:05 UTC


Attachments (Terms of Use)
script file with some debug output upon running evolution (deleted)
2005-10-14 09:39 UTC, Deepak N
no flags Details

Description Chris Lee 2005-05-09 16:11:54 UTC
Description of problem: Exchange support in Evolution does not work. After
adding an Exchange account (stored on an Exchange 2003 server) to the Evolution
client, I cannot use it because Evolution gives me several error dialogs.

The error message when I try to connect is:
"Error: Could not connect to [server]: Cannot connect to destination"

Version-Release number of selected component (if applicable): 
evolution-1.4.5-12
evolution-connector-1.4.7-5

How reproducible: Always

Steps to Reproduce:
1. Configure Exchange 2003 account on Evolution client
2. Click "Send/Receive Messages"
3. Read error message
  
Actual results: Error message

Expected results: All of my Exchange resources should be available

Comment 2 Dave Malcolm 2005-05-10 18:29:45 UTC
Please can you run this test:
 1) Close Evolution
 2) Open a terminal.
 3) Type the following:
    3.1)  script                              
    3.2)  evolution --force-shutdown          
    3.3)  export E2K_DEBUG=4 
    3.4)  /usr/libexec/evolution/1.4/evolution-exchange-storage &
    3.5) evolution &
 4) Evolution should now start; try to connect to your account on the Exchange
server.
 5) Type "exit" to finish the script command and its logging
Please attach the "typescript" file

Comment 3 Dave Malcolm 2005-06-17 22:07:45 UTC
Did you ever reproduce this?

Comment 5 Deepak N 2005-10-14 09:39:54 UTC
Created attachment 119964 [details]
script file with some debug output upon running evolution

Comment 6 Dave Malcolm 2005-10-14 19:50:05 UTC
There are many ways to configure Exchange, and it's not clear from the original
report how it was set up.  This bug should either have been closed, or clarified
with more information on the configuration of the server; the connector has
worked for me with RHEL3 in my tests.

With the above in mind, I'm going to resolve this bug as WORKSFORME

Deepak N: Thanks for attaching the debug output.  Unfortunately it's not very
useful for identifying the problem without more context.  If you have a support
agreement with Red Hat, I'd recommend contacting Red Hat Support, and we can
establish the details of the problem; otherwise, please open this as a separate
bug, so that we can be sure of the details of your situation without confusion.
 Thanks.


Note You need to log in before you can comment on or make changes to this bug.