Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157220 - Heavy network activity starts dropping packets in dom0
Summary: Heavy network activity starts dropping packets in dom0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 15:22 UTC by AJ Lewis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-09 02:20:32 UTC


Attachments (Terms of Use)
lspci -vv output (deleted)
2005-05-25 22:46 UTC, AJ Lewis
no flags Details

Description AJ Lewis 2005-05-09 15:22:36 UTC
Description of problem:
After starting a period of heavy network activity, my xen0 domain stops sending
packets to the network for long periods of time.

Version-Release number of selected component (if applicable):
2.6.11-1.1286_FC4, but I've been seeing this since around 1250.

How reproducible:
Shows up within a day or at most two of booting the xen0 domain.

Steps to Reproduce:
1. Startup xen
2. Do heavy network load
3. Watch the network stop responding
  
Actual results:
Network doesn't respond for several seconds at a time

Expected results:
Network works normally.

Additional info:
I notice this either because my connection to NFS stops working, or I'm working
from home and ssh keeps dropping my connection.  Corresponding standard smp
kernels of the same version work fine.  I am using the e1000 driver.

Comment 1 AJ Lewis 2005-05-19 19:18:53 UTC
More info:

This only happens once I start up a domU.  I *think* it happens when the domU
starts doing network I/O.  It appears that only NFS on the dom0 has problems, as
my ssh connection to my irc session kept running.  My NFS mount line looks like
this:
automount(pid2606) on /nethome type autofs (rw,fd=4,pgrp=2606,minproto=2,maxproto=4)

Comment 2 AJ Lewis 2005-05-25 22:46:58 UTC
Created attachment 114858 [details]
lspci -vv output

Added output of lspci -vv from the system I'm seeing this problem on.

Comment 3 AJ Lewis 2005-05-25 22:49:21 UTC
Tried changing my NFS connection to use TCP, but the problem persisted.  I was
wrong in comment #1 - the network is responding normally, except for NFS.  I can
ssh in to the machine and do anything as long as I don't touch NFS.  I was
unable to 'service portmap stop' (it hung) - so it may be a service that NFS
relies on that is hanging.  Note that when I use TCP to mount NFS, I don't get
any messages about the NFS server not responding like I did with UDP.

Comment 4 Fedora Update System 2005-08-26 21:37:49 UTC
From User-Agent: XML-RPC

A new Xen version has been pushed to Fedora Core 4 updates.  This version of Xen (combined with the latest kernel update) should fix this issue.

Please reopen this bug if the problems continue with the latest Xen and kernel updates.

Comment 5 Fedora Update System 2005-08-30 03:25:09 UTC
From User-Agent: XML-RPC

A new Xen version has been pushed to Fedora Core 4 updates.  This version of Xen (together with kernel 2.6.12-1.1435 or newer) should fix this issue.

Please reopen this bug if the problems continue with the latest Xen and kernel updates.

Comment 6 Rik van Riel 2006-02-09 02:20:32 UTC
This is probably gone in the current Fedora Core 5 Xen kernels, thanks to a
change in the network setup. 


Note You need to log in before you can comment on or make changes to this bug.