Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157212 - Winbind have memory leak
Summary: Winbind have memory leak
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 14:25 UTC by Marc Olivier Chouinard
Modified: 2014-08-31 23:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-31 21:30:11 UTC


Attachments (Terms of Use)

Description Marc Olivier Chouinard 2005-05-09 14:25:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
We have 500 users connected to Samba as a print server.  We are authenticating from Active Directory (2003) using Winbind.  The setup was done using authconfig (plus addition of mkhomedir in the pam.d folder).

After a few days winbind jump from 4mb to 640mb.  And will eventually take all the ram (We do these check now because the box crashed once because of lack of memory).  Stoping and starting the winbind service 'fix' the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure Winbind with Active Directory authentification
2. Make 500 users use it every day
3. Check the memory usage of winbind
  

Actual Results:  Memory usage increase until the box crash or winbind service is restarted

Expected Results:  It should clean memory itself

Additional info:

Comment 1 Marc Olivier Chouinard 2005-10-04 03:26:55 UTC
Daily service winbindd restart fixed the problem.. But still

Comment 2 RHEL Product and Program Management 2006-08-18 17:43:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Nalin Dahyabhai 2006-08-28 21:35:41 UTC
Could you attach your /etc/sysconfig/authconfig, /etc/samba/smb.conf,
/etc/krb5.conf configuration files and the /var/log/samba/winbindd.log log
files?  That may assist in reproducing the leak on a test system.  Thanks!

Comment 4 Marc Olivier Chouinard 2006-08-29 14:16:06 UTC
The system had to be removed from production quite a while ago, moved back to
Windows 2003 !!!! Alittle late for me to provide you with any info.

Comment 6 RHEL Product and Program Management 2006-08-31 21:30:12 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.