Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157201 - When doing a text-mode kick-start install the command "lvm vgchange -a y" is not run for LVM volumes
Summary: When doing a text-mode kick-start install the command "lvm vgchange -a y" is ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 11:12 UTC by Russell Coker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 21:07:11 UTC


Attachments (Terms of Use)
Kickstart configuration. (deleted)
2005-05-16 20:33 UTC, Russell Coker
no flags Details

Description Russell Coker 2005-05-09 11:12:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
I have a kickstart config to install Fedora on LVM volumes.  In GUI mode 
things work fine.  In text mode it attempts to run mkfs without first running 
"lvm vgchange -a y" to create the /dev/mapper nodes, this causes the install 
to fail. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to do a kickstart install onto LVM logical volumes in text mode.  Observe 
that the same install works in GUI mode but not in text mode. 

Additional info:

Comment 1 Russell Coker 2005-05-09 11:47:37 UTC
My initial report lacked an important detail. 
 
I tried the install again with running "lvm vgchange -a y" from the console 
(VT2) at the appropriate time.  All needed /dev/mapper entries were created.  
Then sometime during the step "moving (1) to step enablefilesystems" 
the /dev/mapper entries were removed, possibly at the stage of "formatting 
None as volume group (LVM)" or "formatting None as physical volume (LVM)". 

Comment 2 Jeremy Katz 2005-05-09 15:43:57 UTC
Text vs GUI should be identical as far as this is concerned (all of the steps
which do any of this activation are independent of the UI).  Please provide the
error from when it failed.

Comment 3 Russell Coker 2005-05-13 07:04:49 UTC
I've put pictures of the screen on http://www.coker.com.au/bug/anaconda/ . 
 
Also note that the problem doesn't seem to occur on a machine with 256M of 
RAM, but occurs on machines with 64M of RAM. 

Comment 4 Peter Jones 2005-05-16 18:35:11 UTC
Can you attach your ks.cfg ?

Comment 5 Russell Coker 2005-05-16 20:33:41 UTC
Created attachment 114446 [details]
Kickstart configuration.

Comment 6 Jeremy Katz 2005-05-16 20:53:27 UTC
Can you also provide /tmp/anaconda.log and /tmp/syslog?

Comment 7 Jeremy Katz 2005-09-21 21:07:11 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.