Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157199 - ethereal & tcpdump possible endian issue
Summary: ethereal & tcpdump possible endian issue
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcpdump
Version: rawhide
Hardware: s390x
OS: Linux
medium
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 10:07 UTC by Radek Vokal
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 12:03:52 UTC


Attachments (Terms of Use)

Description Radek Vokal 2005-05-09 10:07:55 UTC
+++ This bug was initially created as a clone of Bug #104424 +++

# TREE Taroon-B2
# ARCH s390, s390x

Looks like there may be an endian issue

mail to <pknirsch AT redhat DOT com>:
> Looking in the changelog for ethereal and tcpdump, looks like you might
> be a good person to bring this issue up with.  In playing around on
> Taroon s390[x] with ethereal and tcpdump, I noticed that the results
> were horribly broken.  None of the fields in the ethereal GUI were being
> mapped correctly.  It jumped out at me as being something endian
> related.  katzj suggested I ping you since you might be able to tell
> rather quickly just by knowing/looking at the code.

response:
Thats actually quite likely. Can you open a bz for it so we can track 
if? Harald is sitting next to me, he's the owner of tcpdump, so we 
should be able to check it out fairly quickly.


# tcpdump -i ctc0 -c 2
tcpdump: listening on ctc0
05:45:55.741330 40:0:40:6:a7:5f 45:10:0:74:e8:a5 c0a8 116:
                         056a ac10 384c 0016 b1b5 2023 0dc9 a582
                         b4cb 8018 2ec0 715b 0000 0101 080a 0014
                         3ffa 0298 dfe8 4300 867f 01d8 518b 63b1
                         25d1 5cd2 d0ae 8a78 b469 b575 cd98 da56
                         5c41 9532 c780 0af7 b835 382f 1b9d cb41
                         8c34
05:45:55.741637 40:0:40:6:a7:3e 45:10:0:94:e8:a6 c0a8 148:
                         056a ac10 384c 0016 b1b5 2023 0e09 a582
                         b4cb 8018 2ec0 23c9 0000 0101 080a 0014
                         3ffa 0298 dfe8 5f07 a7b0 84a9 a599 20e7
                         9c83 c3c4 8625 faf3 73ff 0cd6 3e3b 641a
                         04e1 8cc7 d4e0 37f1 37ef f68b 4621 a8be
                         c63d
2 packets received by filter
0 packets dropped by kernel

[ ethereal screenshot attachment coming soon...]

Comment 1 Martin Stransky 2005-06-23 12:03:52 UTC

*** This bug has been marked as a duplicate of 123663 ***


Note You need to log in before you can comment on or make changes to this bug.