Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157193 - Wireless adapter being detected as wired
Summary: Wireless adapter being detected as wired
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-09 07:36 UTC by SiuPhen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-25 13:24:39 UTC


Attachments (Terms of Use)

Description SiuPhen 2005-05-09 07:36:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Wireless adapter Intel PRO Wireless LAN 2100 3B Mini PCI Adapter on IBM ThinkPad T20 is being detected as wired adapter.  WEP cannot be configured.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 test 2 on IBM ThinkPad T20
2. Try to configure the detected Intel Wireless Pro adapter
3. No option for specifying wireless setting
  

Actual Results:  Wireless setting such as SSID, WEP, etc.... cannot be configured.

Expected Results:  Wireless setting such as SSID, WEP, etc... should be able to configure.

Additional info:

Comment 1 Harald Hoyer 2005-05-09 12:56:25 UTC
So it seems there is no wireless driver in the kernel, or none is configured.
Trick:
add 
TYPE="Wireless"
to the /etc/sysconfig/network-scripts/ifcfg-<name> file.

Comment 2 Dave Jones 2005-06-27 23:13:53 UTC
Mass update for bugs reported against -test:
Updating version field to FC4 final. Please retest with final FC4 release if you
have not already done so. Thanks.

Comment 3 Peter 2005-08-16 17:11:53 UTC
I installed Fedora Core 4 Final (2.6.12-1.1398_FC4) with a Belkin PCMCIA
Wireless card on a DELL Latitude C400.

In the Network Configuration tool the card has been classified as Ethernet and
is working. Currently using to connect to the Wireless router and connecting to
the internet.

I'll try the suggestion of editing the ifcfg file.

Comment 4 Harald Hoyer 2005-08-25 12:46:15 UTC
anaconda should set TYPE="Wireless"

Comment 5 Jeremy Katz 2005-08-25 13:24:39 UTC
Changed anaconda not to set TYPE except in special cases since things can be
probed otherwise.


Note You need to log in before you can comment on or make changes to this bug.