Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157182 - Missing option to fixfiles in rc.sysinit
Summary: Missing option to fixfiles in rc.sysinit
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-08 19:25 UTC by Mathieu Chouquet-Stringer
Modified: 2014-03-17 02:53 UTC (History)
2 users (show)

Fixed In Version: 8.11-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 20:08:25 UTC


Attachments (Terms of Use)

Description Mathieu Chouquet-Stringer 2005-05-08 19:25:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Galeon/1.3.20

Description of problem:
On reboot, if /.autorelabel exists or if the kernel command line contains autorelabel, rc.sysinit will call the relabel_selinux function and will run fixfiles with the following options:
/sbin/fixfiles -F relabel > /dev/null 2>&1

Issue is the command line arguments for fixfiles have changed between FC3 (policycoreutils-1.18.1-2.12) and FC4T2 (policycoreutils-1.23.7-1):
* in FC3, the man page reads:
-F     Dont prompt for removal of /tmp directory.

* while in FC4T2:
-F     Force  reset  of  context to match file_context for customizable files
-f     Dont prompt for removal of /tmp directory.

Bottom line is, if you boot with autorelabel or /.autorelabel, fixfiles will prompt you for /tmp relabeling. STDOUT and STDERR being redirected to /dev/null, one won't see the actual message...

Simple fix is to add -f to the command line (not sure if -F is intended there).

Version-Release number of selected component (if applicable):
initscripts-8.10-1

How reproducible:
Always

Steps to Reproduce:
1. touch /.autorelabel or pass autorelabel to the kernel
2. (re)boot
3. wait for fixfiles
  

Additional info:

Comment 1 Bill Nottingham 2005-05-09 18:54:20 UTC
Will be in 8.11-1. Dan, is this going to be needed for other releases - is the
policycoreutils change going to be backported?

Comment 2 Daniel Walsh 2005-05-09 20:05:08 UTC
Eventually.  For U2 probably.  I can avoid this change, if necessary.  We
changed the -F to be consistant with restorecon and setfiles.  Didn't know it
was being used.  Sorry.

Dan


Note You need to log in before you can comment on or make changes to this bug.