Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157181 - prism54 driver fails with SMC 8028W v2 card
Summary: prism54 driver fails with SMC 8028W v2 card
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-08 17:29 UTC by Kare Nuorteva
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 14:33:04 UTC


Attachments (Terms of Use)
/var/log/messages (deleted)
2005-05-08 17:33 UTC, Kare Nuorteva
no flags Details

Description Kare Nuorteva 2005-05-08 17:29:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
After I configured wireless interface with system-config-network and tried to activate the newly created wireless interface the following error messages are displayed by the system-config-network tool:

Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device eth1 ; Input/output error.

Determining IP information for eth1...SIOCSIFFLAGS: Timer expired
SIOCSIFFLAGS: Timer expired
 failed.



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1226_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install SMC 8028w network card
2. Start pc
3. Download and install firmware from http://prism54.org/
4. Configure wireless interface with system-config-network
5. Try to activate wireless interface
  

Actual Results:  Wireless interface failed activation.

Expected Results:  Wireless interface should activate.

Additional info:

I'm having the exact same problem with FC3 and latest patches.

Comment 1 Kare Nuorteva 2005-05-08 17:33:45 UTC
Created attachment 114141 [details]
/var/log/messages

Comment 2 Kare Nuorteva 2005-05-09 20:48:39 UTC
Upgraded kernel to latest version available (2.6.11-1.1287_FC4) - problem still
persists.

Comment 3 John W. Linville 2005-05-12 14:04:52 UTC
Please attach the output of running "lspci -n" on the box w/ the SMC 8028w 
installed. 
 
Please be specific with which firmware file you are using and what other 
versions you have tried.  Also, how did you rename the firmware file 
downloaded from prism54.org?  That seems to be important... 
 
Have you had this card working with a previous Linux installation?  Do you 
know of others successfully using this card under Linux? 
 
Thanks! 

Comment 4 John W. Linville 2005-06-27 14:33:04 UTC
Closed due to lack of respone...please reopen if/when requested information 
becomes available... 


Note You need to log in before you can comment on or make changes to this bug.