Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157180 - rhythmbox hangs when pausing
Summary: rhythmbox hangs when pausing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-08 16:40 UTC by Jacob Kroon
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 08:21:56 UTC


Attachments (Terms of Use)

Description Jacob Kroon 2005-05-08 16:40:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
Right clicking on Rhythmbox's notification-area icon and then pressing "pause", or  using the general pause button hangs the application. The "Next" and "Previous" commands work, although are mysteriesly slow to complete. This is perhaps not rhythmbox's fault, I rather think it was introduced with the switch to alsa/dmix.

Version-Release number of selected component (if applicable):
rhythmbox-0.8.8-2

How reproducible:
Always

Steps to Reproduce:
(null)

Additional info:

Comment 1 Jacob Kroon 2005-05-10 22:15:13 UTC
I just did a fresh install of FC4 test 3, and the problem remains. (My soundcard
is using the snd-via82xx kernel module).

Comment 2 Jacob Kroon 2005-05-12 08:02:42 UTC
Same thing happens using Beep Media Player, so I guess itsnot related to either
gstreamer or rhythmbox, rather Alsa and the new usage of dmix.

Comment 3 Michael Schwendt 2005-05-13 09:20:19 UTC
Can confirm. FC4T3, snd_ens1371 though.

Other ways to make to hang, too:
 - let a piece of music play till the end
 - "Open in Music Player" another file while the first one plays

Comment 4 Michael Schwendt 2005-05-13 09:27:42 UTC
XMMS from Extras, on the other hand, does not hang when using ALSA output
plugin. While it is playing, I can start simultaneous playback in Rhythmbox and
reproduce the same hangs in Rhythmbox when stopping the music.

Comment 5 Warren Togami 2005-05-13 18:01:42 UTC
What codec are you using for sound when rhythmbox locks up?  OGG?  MP3 (3rd party)?


Comment 6 Michael Schwendt 2005-05-13 18:23:01 UTC
With *.ogg and no gstreamer-plugins-mp3 installed  (and although it's
reproducible with *.mp3, a decoder only influences the audio input data, not the
audio output driver).

Comment 7 Jacob Kroon 2005-05-14 08:56:59 UTC
Same here, I'm using plain old Ogg decoding when it hangs. Not quite sure how to
come up with more useful information about this problem though...

Comment 8 Michael Schwendt 2005-05-15 12:06:11 UTC
Since XMMS here now also locks up some time after playing a file till the end,
this doesn't sound anymore like it's specific to Rhythmbox.

Comment 9 Bill Nottingham 2005-05-24 16:35:13 UTC
This is definitely a dmix issue; it's completely reproducible for me with dmix,
and completely unreproducible for me without it.

Comment 10 Bill Nottingham 2005-05-24 21:00:46 UTC
Should be fixed in alsa-lib-1.0.9rc4-1.

Comment 11 Jacob Kroon 2005-05-25 12:12:26 UTC
Excellent work, all of my problems with rhythmbox/beep-media-player hanging
went away once I updated to alsa-lib-1.0.9rc4-1. DMix is (working) great. 8)


Note You need to log in before you can comment on or make changes to this bug.