Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157177 - segfaults on startup
Summary: segfaults on startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sodipodi
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Leemhuis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 161863 (view as bug list)
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-05-08 12:57 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-19 17:56:54 UTC


Attachments (Terms of Use)

Description John Ellson 2005-05-08 12:57:24 UTC
Description of problem:
segfaults on startup

This happens with both x86_64 binary rpm and with binaries rebuilt from src.rpm

Version-Release number of selected component (if applicable):
sodipodi-0.34-2

How reproducible:
100%

Steps to Reproduce:
1.gdb /usr/bin/sodipodi
2.
3.
  
Actual results:
ellson@ontap:~> gdb sodipodi
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...Using host libthread_db l
ibrary "/lib64/libthread_db.so.1".

(gdb) run
Starting program: /usr/bin/sodipodi
[Thread debugging using libthread_db enabled]
[New Thread 46912496329536 (LWP 6139)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496329536 (LWP 6139)]
nr_svp_from_svl (svl=0x0, flat=0x0) at nr-svp.c:74
74              svp->length = nsegs;
(gdb) where
#0  nr_svp_from_svl (svl=0x0, flat=0x0) at nr-svp.c:74
#1  0x00000000004b8647 in nr_arena_shape_update (item=0x7cf4b0, area=0x0,
    gc=0x7fffffd37af0, state=510, reset=4294967295) at nr-arena-shape.c:386
#2  0x00000000004b554d in nr_arena_item_invoke_update (item=0x7cf4b0,
    area=0x0, gc=0x7fffffd37b80, state=510, reset=4294967295)
    at nr-arena-item.c:224
#3  0x00000000004b73b0 in nr_arena_group_update (item=0x7ced20, area=0x0,
    gc=0x7fffffd37bf0, state=510, reset=4294967295) at nr-arena-group.c:190
#4  0x00000000004b554d in nr_arena_item_invoke_update (item=0x7ced20,
    area=0x0, gc=0x7fffffd37c80, state=510, reset=4294967295)
    at nr-arena-item.c:224
#5  0x00000000004b73b0 in nr_arena_group_update (item=0x7b5d80, area=0x0,
    gc=0x7fffffd37cf0, state=510, reset=4294967295) at nr-arena-group.c:190
#6  0x00000000004b554d in nr_arena_item_invoke_update (item=0x7b5d80,
    area=0x0, gc=0x7fffffd37e20, state=510, reset=4294967295)
    at nr-arena-item.c:224
#7  0x000000000049fac3 in sp_icon_image_load_svg (
    name=0x4ee2c8 "toolbox_file", size=12, scale=12) at icon.c:422
#8  0x000000000049fdd2 in sp_icon_image_load (name=0x4ee2c8 "toolbox_file",
    size=12, scale=12) at icon.c:207
#9  0x000000000049fff0 in sp_icon_new_full (size=12, scale=12,
    name=0x4ee2c8 "toolbox_file") at icon.c:165
#10 0x00000000004a35e3 in sp_toolbox_new (contents=0x6b0810, name=Variable "name
" is not available.
)


Expected results:


Additional info:

Comment 1 Thorsten Leemhuis 2005-05-11 10:27:19 UTC
Fixed in CVS FC-3 with a patch from gentoo; Rebuild done, should be published
soon. Can somebody close this? Thanks.

Comment 2 Michael Schwendt 2005-05-12 21:42:12 UTC
Bug report is about "devel", but there is no sodipodi in "devel". There is only
the older binary copied from FC-3:

  devel: sodipodi-0.34-2.x86_64.rpm
  FC-3: sodipodi-0.34-4.x86_64.rpm 

If sodipodi is obsolete, devel binary ought to get removed.


Comment 3 Thorsten Leemhuis 2005-05-13 04:46:29 UTC
(In reply to comment #2)
> Bug report is about "devel", 

Sorry, didn't see that. Also happens with FC3

> but there is no sodipodi in "devel". There is only
> the older binary copied from FC-3:
> 
>   devel: sodipodi-0.34-2.x86_64.rpm
>   FC-3: sodipodi-0.34-4.x86_64.rpm 
> 
> If sodipodi is obsolete, devel binary ought to get removed.

Probably

Comment 4 Toni Willberg 2005-06-18 17:38:46 UTC
could someone rebuild sodipodi for fc4 too? segfaults for me too

sodipodi-0.34-2.src.rpm


Comment 5 Michael Schwendt 2005-06-18 18:11:32 UTC
sodipodi was killed during Fedora pre-Extras in November 2004. It should not
have been copied into the FC4 repository. I submitted a remove request some
minutes ago.

If somebody wants to bring it back to life, that must start with work in Fedora
Extras CVS first.

Comment 6 Toni Willberg 2005-06-19 13:57:50 UTC
Shall sodipodi be added to the orphaned packages list then?

http://fedoraproject.org/wiki/Extras/OrphanedPackages


Comment 7 Thorsten Leemhuis 2005-06-19 17:56:54 UTC
(In reply to comment #6)
> Shall sodipodi be added to the orphaned packages list then?
> 
> http://fedoraproject.org/wiki/Extras/OrphanedPackages

No, not needed, quoting
https://www.redhat.com/archives/fedora-extras-commits/2005-March/msg00599.html

"Removing sodipodi (was replaced by inkscape)"

Closing this.

Comment 8 Michael Schwendt 2005-07-16 23:43:59 UTC
Reopening, since the remove requests have still not been fulfilled.


Comment 9 Michael Schwendt 2005-07-16 23:44:44 UTC
*** Bug 161863 has been marked as a duplicate of this bug. ***

Comment 10 Adam Pribyl 2005-07-18 07:22:49 UTC
Ehm, so what is the status now? Sodipodi "was removed" but is still in FC4
extras repository?

Comment 11 Michael Schwendt 2005-07-18 09:07:45 UTC
See comment 5 -- waiting for somebody with repository access to remove the old
binary packages.

Comment 12 Michael Schwendt 2005-07-26 09:34:04 UTC
So, this has been fixed finally.



Note You need to log in before you can comment on or make changes to this bug.