Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157176 - exim log processor script fails
Summary: exim log processor script fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-08 10:43 UTC by Frank Ch. Eigler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: logwatch-7.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-09 12:27:28 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2005-05-08 10:43:55 UTC
In logwatch-5.2.2-1.FC3.1 with perl-5.8.5-12.FC3, the .../scripts/services/exim
script fails to start due to its odd use of "eval .. require" construct, and
thus produces empty log reports.

Changing the line 
     eval "require Date::Calc qw(Delta_Days)" or exit 0;
to
     use Date::Calc qw(Delta_Days);
makes it work.

Comment 1 Ivana Varekova 2005-06-28 08:50:10 UTC
This problem should be fixed in the latest logwatch version (logwatch-6.1.2-1). 
Could you please try to reproduce this problem with this version. 


Comment 2 Ivana Varekova 2006-01-09 12:27:28 UTC
This problem is fixed in the last devel version (since logwatch-7.0-1)


Note You need to log in before you can comment on or make changes to this bug.