Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157169 - yum update of perl-5.8.5-9 to perl-5.8.5-12.FC3 fails with conflicts
Summary: yum update of perl-5.8.5-9 to perl-5.8.5-12.FC3 fails with conflicts
Keywords:
Status: CLOSED DUPLICATE of bug 156288
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-08 03:13 UTC by Brian Daniels
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-08 03:38:42 UTC


Attachments (Terms of Use)

Description Brian Daniels 2005-05-08 03:13:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
x86_64 FC3 system that has been reqularly updated with 'yum update'.  My yum config points to:
mirrorlist=http://fedora.redhat.com/download/mirrors/updates-released-fc3.us.east

When 'yum update' is run, generates the errors below.  It appears that the  perl-5.8.5-12.FC3 package has errors.  Others are reporting this at:
http://www.linuxquestions.org/questions/history/318543

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package perl.x86_64 3:5.8.5-12.FC3 set to be updated
--> Running transaction check
Transaction Check Error:   file /usr/lib/perl5/5.8.5/File/Path.pm from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
...

Version-Release number of selected component (if applicable):
perl-5.8.5-12.FC3

How reproducible:
Always

Steps to Reproduce:
1. run yum update
2.
3.
  

Actual Results:  Update fails with conflict errors

Expected Results:  Update should apply error-free

Additional info:

Comment 1 Warren Togami 2005-05-08 03:38:42 UTC

*** This bug has been marked as a duplicate of 156288 ***


Note You need to log in before you can comment on or make changes to this bug.