Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157158 - Button repainting is slow
Summary: Button repainting is slow
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 19:42 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-04 23:00:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 50857 None None None Never

Description Robin Green 2005-05-07 19:42:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
Openoffice.org takes a few seconds to repaint all its buttons every time you do something like save.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start oowrite
2. Save the blank document
  

Actual Results:  Buttons are slowly repainted

Expected Results:  Buttons should be repainted in a fraction of a second

Additional info:

Comment 1 Robin Green 2005-05-07 19:51:08 UTC
For an even slower save, try saving something in OpenOffice Draw. There are more
buttons to repaint, so it takes longer - and it also does apparently unnecessary
no-change repaints (disabled->disabled) as well.

Sorry, I omitted the version number: openoffice.org-draw-1.9.96-2

Comment 2 Caolan McNamara 2005-06-09 12:16:05 UTC

*** This bug has been marked as a duplicate of 158489 ***

Comment 3 Robin Green 2005-06-20 10:55:20 UTC
Reopening. I am still seeing this in openoffice.org-core-1.9.109-6.2.0.fc5


Comment 4 Caolan McNamara 2005-06-27 13:47:47 UTC
are you using kde or something ?

Comment 5 Robin Green 2005-06-27 14:02:55 UTC
Yes, I am using KDE.

Comment 6 Caolan McNamara 2005-06-27 14:13:09 UTC
possibly http://www.openoffice.org/issues/show_bug.cgi?id=50857 then, I'll give
that patch a go and respin

Comment 7 Caolan McNamara 2005-06-28 12:47:50 UTC
When 1.9.112 hits the ftpsite/mirrors can you see if that makes any difference
to you.

Comment 8 Robin Green 2005-07-04 23:00:08 UTC
Yes, it is working for me now.


Note You need to log in before you can comment on or make changes to this bug.