Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157156 - Right "windows key" doesn't generate any key events
Summary: Right "windows key" doesn't generate any key events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 154448 (view as bug list)
Depends On:
Blocks: 154448
TreeView+ depends on / blocked
 
Reported: 2005-05-07 19:26 UTC by Göran Uddeborg
Modified: 2015-01-04 22:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 11:33:00 UTC


Attachments (Terms of Use)

Description Göran Uddeborg 2005-05-07 19:26:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
There are no key events from the right "windows" key.  If I on a virtual console run "showkey -s", nothing is printed when I press the right hand "windows key".

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1226_FC4

How reproducible:
Always

Steps to Reproduce:
1.Run showkey -s
2.Press right hand side "windows key".

Actual Results:  Nothing

Expected Results:  Some scan codes

Additional info:

I'm using a Swedish keyboard.  /etc/sysconfig/keyboard has KEYBOARDTYPE="pc" and KEYTABLE="sv-latin1".  It worked fine with FC3 and older kernels.

I suspect this bug could be the underlying reason for the problems I reported in bug 154448.  With xev this key reports mouse events.  But I know too little about how X do things so I'm not sure, and report it separately.

Comment 1 Kris Ven 2005-06-23 20:28:46 UTC
I'm confirming this behavior with FC4 final. Running 'showkey -s' does not
record it when the right windows key is pressed. The left windows key is
recognized however.

In X Windows (KDE/Gnome), xev reports the key as mouse button 4 (scroll up).

Comment 2 Dave Jones 2005-06-27 23:12:32 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Comment 3 Göran Uddeborg 2005-06-29 12:51:59 UTC
Kris Ven had already confirmed it in FC4 final in comment 1.  Now I too have
tested it there, with all patches applied.  The bug is still there.

Comment 4 Göran Uddeborg 2005-07-02 21:39:24 UTC
After installing kernel-2.6.12-1.1387_FC4 the problem appears to be gone.  The
key shows up with shwokey, and also behaves correctly in X again.

Comment 5 Kris Ven 2005-07-03 09:58:43 UTC
I cannot confirm whether the new kernel (2.6.12-1.1387_FC4) solves the problem,
since it kernel panics on boot up. I'll have to file/search a separate bug
report for that first. I'll report on this bug, once I got the new kernel working.

Comment 6 Göran Uddeborg 2005-07-06 11:33:00 UTC
I've verified some more (on i386 and x86_64), and am convinced this is solved
with the 2.6.12 kernel.  If you should find otherwise Kris Ven, reopen.  (Or
file a new.)

Comment 7 Göran Uddeborg 2005-07-06 11:38:44 UTC
*** Bug 154448 has been marked as a duplicate of this bug. ***

Comment 8 Kris Ven 2005-07-07 17:38:57 UTC
I installed the kernel on a different machine on which the kernel *does* work,
and the problem has disappeared. This bug has indeed been solved.


Note You need to log in before you can comment on or make changes to this bug.