Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157151 - FC 4 Updates erase Sun Jdk/Jre
Summary: FC 4 Updates erase Sun Jdk/Jre
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
: 156116 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-07 18:08 UTC by Steve Romero
Modified: 2014-01-21 22:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 22:10:38 UTC


Attachments (Terms of Use)
log files from described events (deleted)
2005-05-07 18:08 UTC, Steve Romero
no flags Details

Description Steve Romero 2005-05-07 18:08:28 UTC
Description of problem:
Several updates from FC4 test have erased rpm installed Sun JRE from the system.

Version-Release number of selected component (if applicable):
JRE 1.5

How reproducible:
Install Sun Jre.
Update regularly and check Yum logs.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Sun Jre erased from system.

Expected results:
Would have expected FC updates to leave this alone.

Additional info:

Note that I did not identify a system component as I'm not certain just what is
causing this.

See attached log files from selected dates when this occured.

Comment 1 Steve Romero 2005-05-07 18:08:28 UTC
Created attachment 114124 [details]
log files from described events

Comment 2 Seth Vidal 2005-05-07 22:33:50 UTC
reassigning to rpm as yum doesn't have any control over implicit obsoletes.


Comment 3 Jeremy Katz 2005-05-19 00:56:22 UTC
*** Bug 156116 has been marked as a duplicate of this bug. ***

Comment 4 Paul Nasrat 2005-05-19 20:52:20 UTC
rpm -qp --provides jdk-1_5_0_03-linux-i586.rpm
jre = 1.5.0_03
j2sdk = 1.5.0_03
j2re = 1.5.0_03
jaxp_parser_impl
xml-commons-apis
jdk = 2000:1.5.0_03-fcs

D: ========== tsorting packages (order, #predecessors, #succesors, tree, depth,
breadth)
D:     0    0    0    1    1    0   -jdk-1.5.0_03-fcs.i586


  /* On upgrade, erase older packages of same color (if any). */
  mi = rpmtsInitIterator(ts, RPMTAG_PROVIDENAME, rpmteN(p), 0);

Comment 5 Seth Vidal 2005-05-19 21:52:34 UTC
So if you change RPMTAG_PROVIDENAME to RPMTAG_NAME

does the problem vanish?

and how many other, weirder problems does it create?

Comment 6 Paul Nasrat 2005-05-19 22:10:38 UTC
This is really the sun package not designed in a way to integrate with the rest
of the java/rpm world (JPackage). JPackage is recognised and used by the major
Linux RPM vendors.

See also:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4680244
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4680244

Work around for you is to use the jpackage style rpm built from the
self-exploding binary (not the sun rpm) - see http://jpackage.org/rebuilding.php
http://jpackage.org/faq.php.  

An external howto is here http://www.mksearch.mkdoc.org/howto/jpackage-sun-fc3/

This is the best solution as you get a nicer laid out jdk that plays with the
Fedora java design and implementation (as it's based off JPackage). I'll try and
get something in the release notes about it - (probably "for proprietory JDKs
please use packages JPackage 

Changing rpm to not key off PROVIDENAME at this time for FC4 is not tenable.


Note You need to log in before you can comment on or make changes to this bug.