Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157150 - privoxy does not start (selinux denied)
Summary: privoxy does not start (selinux denied)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 17:55 UTC by Sarantis Paskalis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.23-14-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-04 23:43:40 UTC


Attachments (Terms of Use)

Description Sarantis Paskalis 2005-05-07 17:55:55 UTC
Description of problem:

Privoxy service startu fails with the following messages:
May 07 20:45:30 Privoxy(-1208719680) Info: loading configuration file
'/etc/privoxy/config':
May 07 20:45:30 Privoxy(-1208719680) Fatal error: can't bind to 127.0.0.1:8118:
because Permission denied

Relevant snip from logfile:
May  7 20:45:30 gallagher kernel: audit(1115487930.817:0): avc:  denied  {
name_bind } for  src=8118 scontext=root:system_r:privoxy_t
tcontext=system_u:object_r:http_cache_port_t tclass=tcp_socket

Version-Release number of selected component (if applicable):
privoxy-3.0.3-7
selinux-policy-targeted-1.23.14-2
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1. service privoxy start
2.
3.
  
Actual results:


Expected results:


Additional info:
Machine updated from fc3 to rawhide without any obvious problems.

Comment 1 Daniel Walsh 2005-05-07 18:23:22 UTC
Fixed in selinux-policy-targeted-1.23-14-4


Note You need to log in before you can comment on or make changes to this bug.