Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157137 - Re-attaching of USB Mass storage device fails unless usb-storage is rmmod-ed
Summary: Re-attaching of USB Mass storage device fails unless usb-storage is rmmod-ed
Keywords:
Status: CLOSED DUPLICATE of bug 156167
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 13:47 UTC by Eugene Roux
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 21:31:57 UTC


Attachments (Terms of Use)

Description Eugene Roux 2005-05-07 13:47:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Galeon/1.3.20

Description of problem:
If I connect my external hard disk, a 120G WDC HDD in a Cypress Semiconductor USB-2.0 IDE Adapter, usbcore will load usb-storage and gnome-volume-manager / Nautilus will automount the drive.

If I then unmount and disconnect the device it will not be re-mounted on re-connection. D-BUS will see it and HAL, at least according to the HAL Device Manager, detects it.

If, however, I rmmod usb-storage after I disconnect the device it gets automounted just fine on reconnection.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1. Connect Cypress external HDD
2. gnome-volume-manager automounts it
3. Unmount and disconnect external HDD
4. Re-connect external HDD
5. gnome-volume-manager does /not/ automount

Actual Results:  gnome-volume-manager does not automount the external HDD

Expected Results:  gnome-volume-manager should automount the external HDD

Additional info:

kernel-2.6.11-1.1286_FC4
hal-0.5.1-1
gnome-volume-manager-1.3.1-1
dbus-0.33-2
udev-057-3
hotplug-2004_09_23-5

Comment 1 David Zeuthen 2005-05-10 21:31:57 UTC
This surely looks like a duplicate of bug 156167.

*** This bug has been marked as a duplicate of 156167 ***


Note You need to log in before you can comment on or make changes to this bug.