Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157124 - eog,gqview print annoying "load_inc" message to console
Summary: eog,gqview print annoying "load_inc" message to console
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 04:56 UTC by David Costanzo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 12:41:39 UTC


Attachments (Terms of Use)
24bpp-320x240.bmp -- A bitmap file that demonstrates the bug (deleted)
2005-05-07 04:58 UTC, David Costanzo
no flags Details

Description David Costanzo 2005-05-07 04:56:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.7.7-2

Description of problem:
Two applications that use gtk2 (eog and gqview) both print out lots of annoying "load_inc" message to the console when they load bitmap files.  This is probably a printout that was accidently left in a recent patch.

By running the "strings" utility on my ".so" files, I have found the string in 

  /usr/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-bmp.so

I downloaded the source rpm to look for the printf, but I didn't find it.  This may be because the source RPM (gtk2-2.6.4-2.src.rpm) is a little older than the binary RPM (gtk2-2.6.7-2.rpm).  The "strings" utility also shows some other strange words in the .so ("bleh" and "blurb"), but I haven't seen an application print these out.  I have seen a "bla" printout, but only in gqview.


Version-Release number of selected component (if applicable):
gtk2-2.6.7-2

How reproducible:
Always

Steps to Reproduce:
1. Execute "eog 24bpp-320x240.bmp" from the command-line

Actual Results:  eog starts up and displays the image.  It also prints out the following to the console:

load_inc
load_inc
load_inc
load_inc
load_inc


Expected Results:  eog starts up and displays the image.  Nothing is printed to the console.

Additional info:

Comment 1 David Costanzo 2005-05-07 04:58:17 UTC
Created attachment 114112 [details]
24bpp-320x240.bmp -- A bitmap file that demonstrates the bug


Note You need to log in before you can comment on or make changes to this bug.