Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157123 - [miscompilation] libmngbuildcore.jar: Eclipse CDT managed makefile unusable
Summary: [miscompilation] libmngbuildcore.jar: Eclipse CDT managed makefile unusable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 04:37 UTC by josip
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: eclipse-cdt-3.0.0_fc-0.M6.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-04 14:46:14 UTC


Attachments (Terms of Use)

Description josip 2005-05-07 04:37:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
Eclipse managed makefile (C project) contains strings "null" where newlines ought to be.  This makes the makefile unusable.

Version-Release number of selected component (if applicable):
eclipse-cdt-3.0.0_fc-0.M6.5

How reproducible:
Always

Steps to Reproduce:
1.Create a C project with managed makefile in Eclipse
2.Create a "hello world" program
3.Corrupt makefile is unusable
  

Actual Results:  Eclipse managed makefile contains strings "null" where a newline character "\n" ought to be.  The same problem exists in the include files created by Eclipse.

Expected Results:  Proper makefile and its include files should have been created.

Additional info:

Eclipse platform and CDT plugin downloaded from eclipse.org to a Fedora Core 3 platform do not exhibit this problem.  This problem is seen on a Fedora Core 4 test 2 platform with the following Eclipse packages:

eclipse-cdt-3.0.0_fc-0.M6.5
eclipse-ecj-3.1.0_fc-0.M6.14
eclipse-platform-devel-3.1.0_fc-0.M6.14
eclipse-platform-3.1.0_fc-0.M6.14
eclipse-pydev-0.9.3_fc-7
eclipse-jdt-3.1.0_fc-0.M6.14
eclipse-pde-3.1.0_fc-0.M6.14
eclipse-bugzilla-0.1.0_fc-14
eclipse-changelog-2.0.1_fc-21

Comment 1 Anthony Green 2005-05-08 01:30:32 UTC
For what it's worth, I was just about to file this same bug.  I'm seeing "null"
instead of "\n".  Managed makefile projects are unusable right now.


Comment 2 Andrew Overholt 2005-05-09 14:20:00 UTC
Rick/Jeremy/Someone:  can you please take a look at this?

Comment 3 Rick Moseley 2005-05-09 15:24:47 UTC
This only happens when using gcj, everything is fine when using a JVM.  Could be
a gcj-related bug?  I have seen this in the past on other files too when using
gcj but everything is OK under a JVM.

Comment 4 Rick Moseley 2005-05-10 20:33:24 UTC
This thing is pretty flaky.  When I pull in the plugin that generates the
makefile and associated files and try to run as a runtime workbench with "print"
statements it seems to work fine, line breaks are put in correctly.  Hmmm, may
have to just put print statements in and rebuild /reinstall. *sigh*

Comment 5 Ben Konrath 2005-05-10 23:02:30 UTC
Sounds like it could be a miscompilation problem. Can you try moving the
offending  jar.so out of the way (ie move it to jar.so.bk) and then start
eclipse and look for the bug again. BTW, which plugin generates the makefile?
Thanks, Ben

Comment 6 Rick Moseley 2005-05-11 13:26:14 UTC
I agree with your assessment that this is a miscompilation problem.  I tried
what you suggested (moving offending jar to jar.bk) but when I do this I cannot
bring up the C Managed Build wizard to create a managed C project, I get this error:

  The selected wizard could not be started:
    reason:  while resolving class
org.eclipse.cdt.managedbuilder.ui.wizards.NewManagedProjectWizard

The plugin I renamed was org.eclipse.cdt.managedbuilder.core.  The package/class
in there that seems to be causing the problem is
org.eclipse.cdt.managedbuilder.makegen.gnu/GnuMakefileGenerator.java.

I can still check out that plugin and run in the runtime workbench and all the
files(makefile, objects.mk, sources.mk, subdir.mk) seem ok.  One problem I do
get is that I cannot bring up the makefile in any editor.  I get a long message
like "Unable to create editor.  This message may be due to a bug in the
editor...blah, blah, blah".  But I can look at the makefile with outside tools
and it looks fine. 

I am using all of the latest compilers and versions of eclipse as of 5/10/2005.

Comment 7 Ben Konrath 2005-05-11 22:25:00 UTC
Doing this worked for me: 

mv
/usr/lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.core_3.0.0/libmngbuildcore.jar.so{,.bak}

I'm not sure what is causing the other errors. I'm going try to get this into
the rpm. 

Comment 8 Ben Konrath 2005-05-12 00:17:36 UTC
The work-around for this is in eclipse-cdt-3.0.0_fc-0.M6.6. I've requested that
this new package be included with FC4.

Comment 9 josip 2005-10-04 14:46:14 UTC
Current eclipse-cdt-3.0.0_fc-0.M6.7 also seems to work fine.  I consider this
bug closed.


Note You need to log in before you can comment on or make changes to this bug.