Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157084 - Volume applet uses stock Gnome icon instead of Bluecurve one
Summary: Volume applet uses stock Gnome icon instead of Bluecurve one
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-06 18:06 UTC by Joachim Frieben
Modified: 2013-03-13 04:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-14 19:46:23 UTC


Attachments (Terms of Use)
different sizes of volume icons for Bluecurve (deleted)
2005-05-07 05:30 UTC, Matthias Clasen
no flags Details

Description Joachim Frieben 2005-05-06 18:06:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Epiphany/1.6.1

Description of problem:
The new Gnome volume panel applet still uses the stock Gnome icon.

Version-Release number of selected component (if applicable):
redhat-artwork-0.122-6

How reproducible:
Always

Steps to Reproduce:
1. Log in to Gnome session with enabled audio device.
2. Check volume applet panel icon.
  

Actual Results:  Uses the stock Gnome icon.

Expected Results:  Should use the already existing Bluecurve "icon-sound.png" icon when the Bluecurve icon theme was chosen.

Additional info:

None.

Comment 1 Matthias Clasen 2005-05-07 05:30:30 UTC
Created attachment 114113 [details]
different sizes of volume icons for Bluecurve

John, here are the volume icons which Diana did for Bluecurve. 
Beyond adding these to redhat-artwork, the mixer applet needs some
code changes. Currently, it uses gtk_icon_theme_load_icon to load the
icon, but that does not guarantee that the icon is actually of the right
size (as you will see if you play with panel sizes after installing 
Dianas icons). The applet must either a) scale the icon or b) use
gtk_icon_theme_get_icon_info to get the filename, and load it with 
gdk_pixbuf_load_at_size. b) is preferable, since a) may end up scaling 
the icon twice.

Comment 2 John (J5) Palmieri 2005-05-11 18:13:38 UTC
fixed in rawhide

Comment 3 Joachim Frieben 2005-11-14 09:12:00 UTC
It's back: redhat-artwork-0.130-1

Comment 4 John (J5) Palmieri 2005-11-14 14:13:19 UTC
This should be fixed in 131-1 that I packaged last night.  Please confirm. Thanks.

Comment 5 Joachim Frieben 2005-11-14 19:46:23 UTC
Fixed in "redhat-artwork-0.131-1". Great!


Note You need to log in before you can comment on or make changes to this bug.