Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157068 - Apache:mod_ssl:Error: Private key not found
Summary: Apache:mod_ssl:Error: Private key not found
Keywords:
Status: CLOSED DUPLICATE of bug 157062
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mod_ssl
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-06 16:14 UTC by Bill Blackford
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 14:59:31 UTC


Attachments (Terms of Use)

Description Bill Blackford 2005-05-06 16:14:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Same error as Bug 144274.
After generating a new private key and new testcert, restarting httpd returns and error stating that the private key cannot be found.

Version-Release number of selected component (if applicable):
mod_ssl-2.0.52-9.ent.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rm /etc/httpd/conf/ssl.key/server.key
2. rm /etc/httpd/conf/ssl.crt/server.crt
3. cd /usr/share/ssl/certs
4. make genkey
5. make testcert
6. /sbin/service httpd restart
7. Observe error.

  

Actual Results:  Starting httpd: Apache/2.0.52 mod_ssl/2.0.52 (Pass
Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide the pass phrases.

Server rhel4.int.blackfordcomputing.com:443 (RSA)
Enter pass phrase:Apache:mod_ssl:Error: Private key not found.
**Stopped
[FAILED]


Expected Results:  Normal behavior. Apache should start properly and serve https following the pass phase input. This has been verified with rhel3, update 4 and FC1.

Additional info:

This error renders the use of https insecure if the only way it works is via the temporary key and cert.

Comment 1 Joe Orton 2005-05-09 14:59:31 UTC

*** This bug has been marked as a duplicate of 157062 ***


Note You need to log in before you can comment on or make changes to this bug.