Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157050 - Add support for RLIMIT_NICE and RLIMIT_RTPRIO
Summary: Add support for RLIMIT_NICE and RLIMIT_RTPRIO
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
: 157516 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-06 13:29 UTC by Vegard Lima
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: pam-0.80-1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 19:51:52 UTC


Attachments (Terms of Use)
add nice and rt_priority to pam_limits (deleted)
2005-05-06 13:29 UTC, Vegard Lima
no flags Details | Diff

Description Vegard Lima 2005-05-06 13:29:07 UTC
Description of problem:

Add a pair of rlimits for allowing non-root tasks to raise nice and rt
priorities was recently added to the linux kernel.
Something like the attached patch should add pam support for
these two limits.

See also:
http://www.steamballoon.com/wiki/Rlimits
http://kernel.org/git/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=e43379f10b42194b8a6e1de342cfb44463c0f6da
http://lwn.net/Articles/134460/

Comment 1 Vegard Lima 2005-05-06 13:29:07 UTC
Created attachment 114079 [details]
add nice and rt_priority to pam_limits

Comment 2 Tomas Mraz 2005-05-06 13:47:43 UTC
CCing jakub because for the patch to be useful the value of RLIMIT_NICE and
RLIMIT_RTPRIO must be defined in the includes.

The question is - when will they be defined there?


Comment 3 Tomas Mraz 2005-05-12 07:36:16 UTC
*** Bug 157516 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.