Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157016 - Kernel panic in drivers/block/cfq-iosched.c:1065
Summary: Kernel panic in drivers/block/cfq-iosched.c:1065
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-06 01:55 UTC by Srihari Vijayaraghavan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-06 22:59:46 UTC


Attachments (Terms of Use)

Description Srihari Vijayaraghavan 2005-05-06 01:55:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
Kernel panic in drivers/block/cfq-iosched.c:1065 during reboot.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3 (vanilla i686)

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Issue the reboot command
2. Observe a kernel panic
3.
  

Actual Results:  Kernel panic (and a lengthy fsck session afterwards, with possible data corruption/loss too)

Expected Results:  Could have rebooted cleanly, without the panic.

Additional info:

Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on unintialized spinlock d6ce3c1c

Comment 1 Srihari Vijayaraghavan 2005-05-06 02:20:20 UTC
Oh, there was heavy load (CPU, memory and IDE hard drive etc..) just before the
reboot and panic. (I was compiling vanilla 2.6.12-rc3-git1.)

Thanks
Srihari

Comment 2 Sitsofe Wheeler 2005-05-06 18:13:17 UTC
Sounds similar to bug #155472

Comment 3 Srihari Vijayaraghavan 2005-05-06 22:59:46 UTC
Actually, you are right. It is indeed a duplicate to #155472. 
 
Thanks 
Hari


*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.