Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157013 - Installer hangs when partitioning SCSI drives on Adaptec AHA-2940UW
Summary: Installer hangs when partitioning SCSI drives on Adaptec AHA-2940UW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-05 23:12 UTC by Phil Houstoun
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-10-03 00:55:56 UTC

Attachments (Terms of Use)

Description Phil Houstoun 2005-05-05 23:12:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308

Description of problem:
I get through most of the install of FC3 just to the point where the drives are about to be partitioned and then the system totally hangs.  Have tried installing from a SCSI CD-ROM and an ATAPI CD-ROM with same results.  As long as the AHA-2940UW is involved, the install fails. Replaced AHA-2940UW with a Symbios 22801 and all works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Ensure AHA-2940UW in a PCI slot and SCSI drive attached
2.Attempt to install FC3

Actual Results:  Install hangs at disk partitioning

Expected Results:  Complete install of FC3 and happy user.

Additional info:

Install of SuSe 9.2 with exact same hardware config succeeds smoothly!

Comment 1 Dave Jones 2005-07-15 20:17:41 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Frank Ch. Eigler 2005-07-19 22:32:46 UTC
A possibly related data point is that the same SCSI card (pci 9004:8178) now
fails to boot with the 2.6.12-1.1372_FC3(smp) kernel.  It has worked fine with
the entire 2.6.11 stream of fc3 kernels.

The default initrd image fails to boot - one time with references to undefined
symbols from spi_*.  A hand-made initrd image, including both aic7xxx and
aic7xxx_old, still fails to scan the bus, and thus the kernel boot aborts when
it tries to mount "/".  The kernel paniced in such a way as to make impossible
transcription of the errors here.

Comment 3 Dave Jones 2005-10-03 00:55:56 UTC
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.