Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156977 - cannot print postscript from KDE apps
Summary: cannot print postscript from KDE apps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 20:18 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 17:31:53 UTC


Attachments (Terms of Use)
print file generated by qt-3.3.4-10 (deleted)
2005-05-11 13:38 UTC, Sammy
no flags Details
print file generated by qt-3.3.4-12 (deleted)
2005-05-11 13:39 UTC, Sammy
no flags Details

Description Sammy 2005-05-05 20:18:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
When I print a postscript file to a printer or a file, the resulting file is not 
readable by ghostscript and does not print. You can use konqueror or 
kmail.  

Version-Release number of selected component (if applicable):
kdelibs-3.4.0-6

How reproducible:
Always

Steps to Reproduce:
1. start konqueror 
2. print any page to a ps file 
3. view with ghostscript 
   

Additional info:

Comment 1 Sammy 2005-05-06 15:29:13 UTC
SOLVED: 
 
The problem is the latest qt-3.3.4-12 going back to qt-3.3.4-10 from test2 solves the 
problem. Generated postscript file between two versions of qt are different. I can't 
tell what is actually causing the problem. 
 
Please reassign this to QT. 
Thanks 

Comment 2 Ngo Than 2005-05-11 12:01:01 UTC
I'm not able to reproduce this problem. It works for me here with current rawhide

if you want to view with fs, you should probably add option -sDEVICE=x11 in the
command line.  gs -sDEVICE=x11 print.ps

Comment 3 Sammy 2005-05-11 13:38:45 UTC
Created attachment 114244 [details]
print file generated by qt-3.3.4-10

Comment 4 Sammy 2005-05-11 13:39:36 UTC
Created attachment 114245 [details]
print file generated by qt-3.3.4-12

Comment 5 Sammy 2005-05-11 13:40:03 UTC
I still have the problem. I tested it multiple times, including creating a brand new user 
and testing it there. I am attaching two postscript files, of this page, to the message. 
The one with -10 coresponds to qt-3.4.0-10 and ditto for -12. See if your ghostscript 
shows -12 with no problem, mine crashes on it. Also, if you do a diff you can see the 
difference in the files. 
 
PS: These were created this morning with everything else identical. 

Comment 6 Ngo Than 2005-05-11 14:46:34 UTC
it seems it's only happen on x86 arch. it works fine on x86_64. It's surely a
compiler bug, which has miscompiled qt-3.3.4-12 again :(




Comment 7 Yusuf Ma 2005-05-13 05:41:47 UTC
I have similar problems. None of KDE programs (Kate, Konqueror, Kedit, Kwrite,
etc.) can print (no matter to the printer or to postscript files). Firefox in
KDE works well. Gnome programs are fine.

My platform is AthlonXP 2500+.

Comment 8 Ngo Than 2005-05-18 17:31:53 UTC
It's now fixed in qt-3.3.4-14, which will be available in rawhide soon.
Many thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.