Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156974 - Unable to rebuild from src rpm
Summary: Unable to rebuild from src rpm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 19:59 UTC by Mike Hoffman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 5.0.4-10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 13:01:40 UTC


Attachments (Terms of Use)

Description Mike Hoffman 2005-05-05 19:59:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Unable to rebuild php-5.0.4-8 from source rpm due to a Kerberos libraries problem.  Src rpm looking for libraries in /usr/kerberos instead of /usr/lib



Version-Release number of selected component (if applicable):
rpmbuild --rebuild php-5.0.4-8.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.download php-5.0.4-8.src.rpm from fedora's development repository
2.rpmbuild --rebuil php-5.0.4-8.src.rpm
  

Actual Results:  fails with the following error:
+/usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
ERROR: file '/usr/lib/php/modules/imap.so' contains an invalid rpath
'/usr/kerberos/lib' in [/usr/kerberos/lib]
error: Bad exit status from /var/tmp/rpm-tmp.3252 (%install)

Expected Results:  build rpms from source

Additional info:

no modifications have been made to the spec file and trying to rebuild from a stock fedora C3 install with everything installed

Comment 1 Joe Orton 2005-05-06 10:29:45 UTC
There is no /usr/lib/rpm/check-rpaths in stock FC3, so that's not quite true, at
least.  However the RPATHs should not be there, indeed.

Comment 2 Joe Orton 2005-05-10 13:01:40 UTC
Fixed in 5.0.4-10 which should hit Raw Hide sometime soon.


Note You need to log in before you can comment on or make changes to this bug.