Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156973 - possible filesystem corruption due to recovery
Summary: possible filesystem corruption due to recovery
Keywords:
Status: CLOSED DUPLICATE of bug 155597
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Marzinski
QA Contact: GFS Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 19:58 UTC by Corey Marthaler
Modified: 2010-01-12 03:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 19:27:39 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-05-05 19:58:56 UTC
Description of problem:
This may be related to 155597.

Three node cluster (link-10,link-12,link-08) and three GFS (on the MSA1000).
After a couple iterations of revolver, link-10 hit 139738, so I rebooted all
three nodes and attmepted to bring the cluster back up. The first two
filesystems mounted just fine, but the third hit this (on all three nodes):

GFS: Trying to join cluster "lock_dlm", "link-cluster:gfs2"
GFS: fsid=link-cluster:gfs2.0: Joined cluster. Now mounting FS...
GFS: fsid=link-cluster:gfs2.0: jid=0: Trying to acquire journal lock...
GFS: fsid=link-cluster:gfs2.0: jid=0: Looking at journal...
GFS: fsid=link-cluster:gfs2.0: jid=0: Acquiring the transaction lock...
GFS: fsid=link-cluster:gfs2.0: jid=0: Replaying journal...
GFS: fsid=link-cluster:gfs2.0: jid=0: Replayed 79 of 1255 blocks
GFS: fsid=link-cluster:gfs2.0: jid=0: replays = 79, skips = 354, sames = 822
GFS: fsid=link-cluster:gfs2.0: jid=0: Journal replayed in 2s
GFS: fsid=link-cluster:gfs2.0: jid=0: Done
GFS: fsid=link-cluster:gfs2.0: jid=1: Trying to acquire journal lock...
GFS: fsid=link-cluster:gfs2.0: jid=1: Looking at journal...
GFS: fsid=link-cluster:gfs2.0: jid=1: Done
GFS: fsid=link-cluster:gfs2.0: jid=2: Trying to acquire journal lock...
GFS: fsid=link-cluster:gfs2.0: jid=2: Looking at journal...
GFS: fsid=link-cluster:gfs2.0: jid=2: Done
GFS: fsid=link-cluster:gfs2.0: Scanning for log elements...
GFS: fsid=link-cluster:gfs2.0: fatal: filesystem consistency error
GFS: fsid=link-cluster:gfs2.0:   function = gfs_increment_blkno
GFS: fsid=link-cluster:gfs2.0:   file =
/usr/src/build/563141-i686/BUILD/smp/src/gfs/recovery.c, line = 326
GFS: fsid=link-cluster:gfs2.0:   time = 1115317369
GFS: fsid=link-cluster:gfs2.0: about to withdraw from the cluster
GFS: fsid=link-cluster:gfs2.0: waiting for outstanding I/O
GFS: fsid=link-cluster:gfs2.0: telling LM to withdraw
lock_dlm: withdraw abandoned memory
GFS: fsid=link-cluster:gfs2.0: withdrawn
GFS: fsid=link-cluster:gfs2.0: *addr = 41481616
  mh_magic = 0x01161970
  mh_type = 8
  mh_generation = 0
  mh_format = 800
  mh_incarn = 0
  lh_flags = 0x00000000
  lh_pad = 0
  lh_first = 41481616
  lh_sequence = 115232
  lh_tail = 41478496
  lh_last_dump = 41481152
  lh_reserved =
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
GFS: fsid=link-cluster:gfs2.0: Failed
GFS: fsid=link-cluster:gfs2.0: can't make FS RW: -5
GFS: fsid=link-cluster:gfs2.0: Unmount seems to be stalled. Dumping lock state...
Glock (8, 1)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
Glock (8, 0)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
GFS: fsid=link-cluster:gfs2.0: Unmount seems to be stalled. Dumping lock state...
Glock (8, 1)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
Glock (8, 0)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
GFS: fsid=link-cluster:gfs2.0: Unmount seems to be stalled. Dumping lock state...
Glock (8, 1)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
Glock (8, 0)
  gl_flags =
  gl_count = 1
  gl_state = 0
  req_gh = no
  req_bh = no
  lvb_count = 1
  object = no
  new_le = no
  incore_le = no
  reclaim = no
  aspace = no
  ail_bufs = no
   	 

Version-Release number of selected component (if applicable):
GFS 2.6.9-32.0 (built May  5 2005 12:12:20) installed

Comment 1 Ben Marzinski 2005-05-09 19:27:39 UTC

*** This bug has been marked as a duplicate of 155597 ***


Note You need to log in before you can comment on or make changes to this bug.