Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156968 - salinfod terminates on valid error status
Summary: salinfod terminates on valid error status
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils
Version: 3.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 170417
TreeView+ depends on / blocked
 
Reported: 2005-05-05 18:26 UTC by Alex Williamson
Modified: 2013-03-06 05:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:02:57 UTC


Attachments (Terms of Use)
the patch (deleted)
2005-05-06 15:47 UTC, Alex Williamson
no flags Details | Diff

Description Alex Williamson 2005-05-05 18:26:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

Description of problem:
See bugzilla 148979 against RHEL4.  RHEL3 has the same bug.  The patch is simply:

--- salinfo-0.5/sal_types.h.orig        2005-05-05 11:43:49.000000000 -0600
+++ salinfo-0.5/sal_types.h     2005-05-05 11:44:03.000000000 -0600
@@ -126,7 +126,7 @@
     ERR_UNIMPL=19, ERR_LOL=20, ERR_RESPONSE=21, ERR_PARITY=22, ERR_PROTOCOL=23,
     ERR_ERROR=24, ERR_TIMEOUT=25, ERR_POISONED=26};
   enum status_bits {
-    STATUS_TYPE_SHIFT=7, ADDRESS=16, CONTROL=17, DATA=18, RESPONDER_BIT=19,
+    STATUS_TYPE_SHIFT=8, ADDRESS=16, CONTROL=17, DATA=18, RESPONDER_BIT=19,
     REQUESTOR_BIT=20, FIRST_ERROR=21, OVERFLOW_BIT=22};
 
   bool err_in_address;

Corrected single bit errors on the system produce an error log that causes salinfod to throw an unhandled exception and die.  This is the most common type of error log produced and expected to be handled by this daemon.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.7

How reproducible:
Always

Steps to Reproduce:
1. Use known bad DIMM
2. Wait for memory errors
3. Look to see that salinfod is no longer running
  

Actual Results:  salinfod quietly dies and does not respawn

Expected Results:  salinfod stays running and collecting error records

Additional info:

Comment 1 Suzanne Hillman 2005-05-06 15:13:26 UTC
Please attach this patch via the "Create a New Attachment" link, as inline
patches can be problematic.

Thanks!

Comment 3 Alex Williamson 2005-05-06 15:47:19 UTC
Created attachment 114083 [details]
the patch

Comment 5 Dave Jones 2005-08-15 18:36:25 UTC

*** This bug has been marked as a duplicate of 148979 ***

Comment 6 Rick Hester 2005-08-15 19:34:42 UTC
Dave,

Although this bug report and 148979 are very similar, I
don't think they should be considered duplicates.  This
one is reported to RHEL v.3 and 148979 is reported to
RHEL v.4.  Closing this one as a duplicate would most likely
result in the problem not getting fixed for v.3 and it
really does need to get fixed.

Comment 8 Red Hat Bugzilla 2007-02-05 19:00:10 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 10 RHEL Product and Program Management 2007-10-19 19:02:57 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.