Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156939 - ntpd crashes under load
Summary: ntpd crashes under load
Keywords:
Status: CLOSED DUPLICATE of bug 177052
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ntp
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 15:19 UTC by Rik van Riel
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: ntp 4.2.0.a.20050816 Release 3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-21 12:44:28 UTC


Attachments (Terms of Use)
RLIMIT_MEMLOCK patch for "out of memory" error (deleted)
2005-10-11 07:12 UTC, Bojan Smojver
no flags Details | Diff
ntp-4.2.0.a.20050816-3.src.rpm (deleted)
2005-10-31 14:57 UTC, Petr Raszyk
no flags Details | Diff

Description Rik van Riel 2005-05-05 15:19:38 UTC
Description of problem:

I run a pool.ntp.org server on my DSL line, but every once in a while (once a
month?) ntpd just crashes. I know this is little to go on, but I have written a
small shell script to monitor ntpd so I can comb through the logs the next time
ntpd crashes.

I hope to have useful info to attach next crash...

Version-Release number of selected component (if applicable):

ntp-4.2.0.a.20040617-4

Steps to Reproduce:
1. run pool.ntp.org server
2. wait a long time
3. *boom*
  
Additional info:

I will get you additional info once I have it. Let me know what kind of info you
want and I can set things up to collect it for you...

Comment 1 Jiri Ryska 2005-05-17 16:44:01 UTC
This may be a duplicate for #154759. Can you please try this?
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=145258#c13


Comment 2 Rik van Riel 2005-05-17 17:01:25 UTC
I had a number of crashes this morning, and have now done the "execshield -s
/usr/sbin/ntpd" workaround.

I will let you know if the crashes continue or stop.

(btw, even if this is a duplicate, this bug should remain open since this one is
against RHEL4 while the other one is against Fedora)

Comment 3 Rik van Riel 2005-05-17 17:02:44 UTC
Sorry, that was "execstack -s /usr/sbin/ntpd" - not execshield ;)

Comment 4 Rik van Riel 2005-05-17 21:09:58 UTC
OK, that didn't help.  ntpd is still crashing every hour or so...

Comment 5 Rik van Riel 2005-05-17 21:11:49 UTC
May 17 17:01:03 imladris ntpd[8108]: ntpd 4.2.0a@1.1190-r Mon Oct 11 09:10:20
EDT 2004 (1)
May 17 17:01:03 imladris ntpd: ntpd startup succeeded
May 17 17:01:06 imladris ntpd[8108]: precision = 1.000 usec
May 17 17:01:06 imladris ntpd[8108]: Listening on interface wildcard, 0.0.0.0#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface wildcard, ::#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface lo, 127.0.0.1#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface eth0, 10.0.13.1#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface eth1, 66.92.77.98#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface eth1:1, 66.92.77.142#123
May 17 17:01:06 imladris ntpd[8108]: Listening on interface tun0, 172.16.83.121#123
May 17 17:01:06 imladris ntpd[8108]: kernel time sync status 0040
May 17 17:01:13 imladris ntpd[8108]: frequency initialized -16.022 PPM from
/var/lib/ntp/drift
May 17 17:01:13 imladris ntpd[8108]: configure: keyword "authenticate" unknown,
line ignored
May 17 17:01:13 imladris ntpd[8108]: too many recvbufs allocated (40)


Comment 6 Rik van Riel 2005-05-17 21:12:27 UTC
This is the lifespan of ntpd when the system is in this state.  It just crashes
within a few seconds of starting up!

Comment 7 Bojan Smojver 2005-10-11 07:11:18 UTC
I just bumped into a similar issue, where ntpd runs out of memory. This patch helps:

http://lists.ntp.isc.org/pipermail/hackers/2005-June/001418.html

Comment 8 Bojan Smojver 2005-10-11 07:12:37 UTC
Created attachment 119792 [details]
RLIMIT_MEMLOCK patch for "out of memory" error

Comment 9 Bojan Smojver 2005-10-11 07:17:32 UTC
Also here:

https://ntp.isc.org/bugs/show_bug.cgi?id=477

Comment 10 Petr Raszyk 2005-10-31 14:58:02 UTC
Created attachment 120569 [details]
ntp-4.2.0.a.20050816-3.src.rpm

Fixed.

Comment 11 Rik van Riel 2005-10-31 15:05:17 UTC
Since the updated ntp package has not yet been released on RHN, I am marking
this bug MODIFIED.

Comment 12 Miroslav Lichvar 2006-03-21 12:44:28 UTC

*** This bug has been marked as a duplicate of 177052 ***


Note You need to log in before you can comment on or make changes to this bug.