Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156933 - obsuce case where killing GUI on cmdline will still cause problems
Summary: obsuce case where killing GUI on cmdline will still cause problems
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 14:48 UTC by Corey Marthaler
Modified: 2009-04-16 20:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 21:52:24 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2005-05-05 14:48:35 UTC
Description of problem:
This is realted to bz 154839. I had the GUI up all night monitoring the cluster
status and this morning killed it on the cmdline which caused this traceback:

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/MgmtTab.py", line 220, in onTimer
    self.prep_service_tree()
  File "/usr/share/system-config-cluster/MgmtTab.py", line 191, in prep_service_tree
    services = self.command_handler.getServicesInfo()
  File "/usr/share/system-config-cluster/CommandHandler.py", line 243, in
getServicesInfo
    out,err,res =  rhpl.executil.execWithCaptureErrorStatus(clustat_path,args)
  File "/usr/lib64/python2.3/site-packages/rhpl/executil.py", line 253, in
execWithCaptureErrorStatus
    select.select([read], [], [])
KeyboardInterrupt


Version-Release number of selected component (if applicable):
-48

How reproducible:
I was not able to reproduce this

Comment 1 Jim Parsons 2005-05-09 21:52:24 UTC
I cannot reproduce this either. 

Comment 2 Jim Parsons 2005-05-09 22:38:40 UTC
I have added an additional trap to try and prevent this.


Note You need to log in before you can comment on or make changes to this bug.