Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156931 - boot hang at "Initializing hardware..." [2.6.11-1.1286]
Summary: boot hang at "Initializing hardware..." [2.6.11-1.1286]
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 14:17 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-10 20:37:30 UTC


Attachments (Terms of Use)

Description John Reiser 2005-05-05 14:17:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
[PowerPC Mac mini] boot hangs:
-----
Starting udev:  MAKEDEV; mkdir: File exists               [OK]
Initializing hardware...
-----
with none of the "storage network audio done" listed.
No response to Ctrl-Alt-DEL.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot PowerPC Mac mini
2.
3.
  

Actual Results:  Hangs at "Initializing hardware..." with no classes listed.


Expected Results:  proceeds with boot

Additional info:

initscripts-8.10-1
kudzu-1.1.116-1
selinux-policy-targeted-1.23.14-2     [targeted enforcing]

Boots OK with kernel-2.6.11-1.1282_FC4.

Comment 1 Gabriel Schulhof 2005-05-05 20:20:46 UTC
The same thing is happening to me running rawhide on my iBook G4 since I ran
"yum update" this morning. I have commented out the section in rc.sysinit
responsible for "Initializing hardware ...", and it booted, but now I have to
manually modprobe the USB stuff, as well as the sound.

In another (possibly unrelated) issue, klogd is spewing a large number of

audit(1115315428.684:0): avc:  denied:  { search } for  name=/ dev=tmpfs
ino=2094 scontext=system_u:system_r:klogd_t tcontext=system_u:object_r:tmpfs_t
tclass=dir

messages to the console, and the mingettys never start, possibly because

audit(1115324297.176:0): avc:  denied  { search } for  name=/ dev=tmpfs ino=2094
scontext=system_u:system_r:getty_t tcontext=system_u:object_r:tmpfs_t tclass=dir

ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/.discinfo
currently reads:

1115290418.152448
Fedora Core 3.92
ppc
1,2,3,4,5
Fedora/base
Fedora/RPMS
Fedora/pixmaps


Comment 2 Phil 2005-05-05 22:48:28 UTC
I have the same problem since kernel 1284, 1282 is ok.  I have a PC dual boot.

Comment 3 Eugene Mah 2005-05-06 19:36:11 UTC
I have been running into the same issue on a Dell GX270. 
kernel-2.6.11-1.1282_FC4 boots up fine, but my USB mouse no longer works. 
kernel-2.6.11-1.1276_FC4 is the last kernel that works reliably for me.

Comment 4 Eugene Mah 2005-05-06 19:42:34 UTC
This problem seems to be the same as bug #156909

Comment 5 Phil 2005-05-08 15:26:22 UTC
kernel-2.6.11-1.1287_FC4, recently released, now works fine for me!!

Comment 6 John Reiser 2005-05-09 14:16:49 UTC
It now "works for me" with:
kernel-2.6.11-1.1287_FC4
initscripts-8.10-1
udev-057-4
selinux-policy-targeted-1.23.14-2  [targeted enforcing]



Note You need to log in before you can comment on or make changes to this bug.