Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156926 - autofs tcp gives errors going to certain netapp boxes
Summary: autofs tcp gives errors going to certain netapp boxes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs
Version: 3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 13:53 UTC by Dwight Marzolf
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 18:37:33 UTC


Attachments (Terms of Use)
output from commands and descriptions of the output (deleted)
2005-05-05 14:03 UTC, Dwight Marzolf
no flags Details

Description Dwight Marzolf 2005-05-05 13:53:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
We have a number of Network Appliance file servers in our company at various sites around the world.  If I enable tcp on autofs and cd via /net to a path on one of these boxes that is not exported in a certain way, I am not able to get to the desired directory.  I get a "file not found" error.  With udp for autofs I can get  to the same directory without a problem. The attached file will show the output from the tcp and udp settings of autofs going to a particular box and the exports file from that netapp box.

Version-Release number of selected component (if applicable):
autofs-4.1.3-120

How reproducible:
Always

Steps to Reproduce:
1.Turn on tcp in autofs by editing /etc/auto.net and adding tcp to the options list.
2.Reboot the workstation to make sure the tcp option is functioning in autofs
3.cd /net/boxname.domain/vol/dir1/dir2
  

Actual Results:  I get the error "No such file or directory"

Expected Results:  I should be able to cd into the directory and do an ls and see the files in the directory.

Additional info:

I will attach a file with output from both tcp and the udp settings going to the same path on the same netapp box.  I will also attach the exports file from the netapp box.

I set the Severity level to high because it looks like with the release of Rhel 3 at our site we will have to go with the tcp setting to solve some other issues.  This will definately keep our users from getting to at least one of our netapp boxes via /net.

Comment 1 Dwight Marzolf 2005-05-05 14:03:58 UTC
Created attachment 114055 [details]
output from commands and descriptions of the output

This attachment show various commands that were tried and description of the
output that suppliments the original bug.

Comment 2 Jeff Moyer 2005-05-05 14:16:32 UTC
Please follow the guidelines for submitting autofs bug reports found here:

  http://people.redhat.com/jmoyer/

Also note that the mount commands you do to show that mount works are not the
same commmands that are issued by autofs.  Check in the debug logs when you
generate them.  Please try the EXACT mount command listed there.

Please also file only one bug per bug report.  Open a separate bug to track the
expiration of directories that have references.

Comment 3 Jeff Moyer 2005-05-11 18:37:33 UTC
Got this update from Dwight:

I went and checked the debug logs and did the mounts exactly as they 
were listed in the log file.  And sure enough, I got the error "nfs 
server reported service unavailable: Address already in use" when I 
tried to the manual mount.  This error message bothered me because web 
research suggests that the error indicates that one of the nfs parties 
does not have tcp active.  I know it's a part of the kernel in rhel 3 
and rpcinfo -p shows both udp and tcp as active on port 2049 on my rhel 
3 machine.  I had the sysadmin for dfiler4 check to see if tcp was 
turned on for this netapp box and it was NOT turned on.  I had him turn 
on tcp and then I tested the /net mounts back to dfiler4.  Everything 
worked fine.

So, it appears that this one is on our end with netapp boxes not having 
tcp enabled.  I had thought that all these boxes were tcp enables by 
default but apparently not.  This also solved the expiration of 
directories as the mount points do not time out from underneath me when 
I have cd to one of the directories on dfiler4.  I would consider this 
issue resolved.

I'm closing this as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.