Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156915 - Ximian no longer an independant package
Summary: Ximian no longer an independant package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Wade
QA Contact: Tammy Fox
URL: http://fedoraproject.org/wiki/FedoraD...
Whiteboard:
Depends On:
Blocks: fc-relnotes-traqr
TreeView+ depends on / blocked
 
Reported: 2005-05-05 11:17 UTC by Karsten Wade
Modified: 2007-04-18 17:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-30 15:49:43 UTC


Attachments (Terms of Use)

Description Karsten Wade 2005-05-05 11:17:45 UTC
Description of problem, bug, incorrect information, or enhancement request:

As gleened from a Wiki entry:


-   * There have been issues observed when upgrading Red Hat Linux 7.<x>, 8.0,
9, and Fedora Core 1 systems running Ximian GNOME. The issue is caused by
version overlap between the official Red Hat Linux RPMs (or the ones from the
Fedora Project) and the Ximian RPMs. This configuration is not supported. You
have several choices in resolving this issue:
+   * There have been several issues observed when upgrading from previous
version of  Red Hat Linux or Fedora Core systems which contain third party
packages that conflict with the ones provided within the Fedora Project. Such
configurations ares not supported.
  
- 1) You may remove Ximian GNOME from your system prior to upgrading to Fedora Core.
- 
- 2) You may upgrade your system, and then immediately reinstall Ximian GNOME.
- 
- 3) You may upgrade your system, and then immediately remove all remaining
Ximian RPMs, replacing them with the corresponding Fedora Core RPMs.
- 
- You must resolve the version overlap using one of the above choices.  Failure
to do so will result in an unstable GNOME configuration.

Version of release notes this bug refers to:

FC4test3

URL of bug/enhancement (change if different):

http://fedoraproject.org/wiki/FedoraDocs/RelNotes/Core4Test3RelNotes

Comment 1 Karsten Wade 2005-05-05 19:40:32 UTC
Some email updates on this:

> >Although you are certainly correct that Ximian GNOME no longer exists,
> >there are definitely users of Red Hat Linux 7.x, 8.0, and 9, and Fedora
> >Core 1, who installed Ximian GNOME when it *did* exist, and who still
> >have it on their systems.  The guidance in the Release Notes is there
> >for their benefit if they upgrade to Fedora Core 4, and not to imply
> >that Ximian GNOME is still around.

> I talked to Warren Togami who suggested this change that release notes 
> mention that any package conflicts due to third party packages will 
> result in a unsupported configuration instead of being specific to 
> Ximian GNOME. I will however let you deal with the decision

OK, I wasn't aware of that.  Changing the statement to cover all third
party packages is definitely a more global disclaimer.  I'm going to
leave this up to Karsten to resolve then.  He can always revert my
reversion.  :-)

## Karsten sez:  the Wiki doesn't count, anyway.  It's what is here in this
bugzilla ticket :)

Comment 2 Paul W. Frields 2005-05-05 20:30:20 UTC
And I hadn't checked BZ for anything on this.  Thanks for the pointer, Karsten.
 Rahul, good catch on the wikified Release Notes, sorry for stepping on your edit!

Comment 3 Karsten Wade 2005-05-30 15:49:43 UTC
Resolved for FC4 final release notes.

The content now pleads the generic case using the specific as an example:

	<para>
	  <remark os="test">(x86)</remark> There have been issues
	  observed when upgrading &RHL;
	  7.<replaceable>&lt;x&gt;</replaceable>, 8.0, 9, and &DISTRO; 1
	  systems where third party packages are installed that conflict
	  with packages provided by &FP;.  One example is Ximian GNOME.
	</para>
	<para>
	  The issue with Ximian GNOME is caused by version overlap
	  between the official &RHL; RPMs (or the ones from the &PROJ;)
	  and the Ximian RPMs.  This configuration is not supported. You
	  have several choices in resolving this particular issue:
	</para>


Note You need to log in before you can comment on or make changes to this bug.