Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156909 - system halts when booting new kernel-2.6.11-1.1284_FC4
Summary: system halts when booting new kernel-2.6.11-1.1284_FC4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 05:17 UTC by Sean Godsell
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 19:07:17 UTC


Attachments (Terms of Use)

Description Sean Godsell 2005-05-05 05:17:37 UTC
Description of problem:
Install the latest updates for FC4 test 2, and the kernel does not boot now.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1284_FC4.i686

How reproducible:
Just boot that kernel version on a toshiba A70 notebook

Steps to Reproduce:
1. Installed FC4 test 2 and all the packages
2. Install all the package updates including kernel-2.6.11-1.1284_FC4
3.
  
Actual results:
stops at Initializing hardware
or right after udev (it gets an error MAKEDEV: dir found)

Expected results:
boot up

Additional info:
Also on this notebook the mouse never works with the FC4 test 2 kernels (any of
them).  So I just download from kernel.org and run my own kernel with ps/2
support and the mouse works fine.  But point being your kernel should work with
my built in mouse.

Comment 1 Tom Wood 2005-05-05 12:23:46 UTC
I can confirm this hanging for both the UP and SMP kernels on a dual PIII, Via
686 chipset (Abit VP6).  Power cycling is required to reboot (three finger
salute doesn't work).

Comment 2 Frank Swasey 2005-05-05 19:48:51 UTC
I'm seeing the same problem on a Dell Lattitude C800 laptop with the
2.6.11-1.1284_FC4 and 2.6.11-1.1286_FC4 UP kernels.  2.6.11-1.1276_FC4 still
boots and works.

Comment 3 Sean Godsell 2005-05-05 20:07:03 UTC
I installed 1286_FC4 and it still dies at Initializing hardware...  But I notice
above is something that I believe is causing the problem.  When udevd is
started, there is a bad message  MAKEDEV: mkdir: File exists.  This should not
be.  Also this started occuring only after 1284_FC4.

Comment 4 Sean Godsell 2005-05-05 20:18:31 UTC
The initrd-xxxx.img is buggered up since 1284_FC4.  This needs to be fixed!

Comment 5 Sean Godsell 2005-05-05 23:12:36 UTC
I found the problem!  Starting in 2.6.11-1.1284_FC4 and above then initrd was
changed.  The init inside the initrd-2.6.11-1.128X_FC4.img was modified.  Lines
7 and 9 were changed from
7:   mount -t sysfs none /sys
to
7:   mount -t sysfs /sys /sys
and line 11 from
11:  mount -o mode=0755 -t tmpfs none /dev
to
11:  mount -o mode=0755 -t tmpfs /dev /dev

This is why there is an error when udev starts up.  The /dev is not mounted and
udev fails.
Note: to self (person making these images) test before release.  Say it again!
Test before release.  :-)
PS. Also get the mouse working please.  I would like to use a stock kernel where
the mouse would actually work.
Thank you.

Comment 6 djh 2005-05-05 23:26:20 UTC
This is a dupe of bug #156862.

Comment 7 Jonathan S. Shapiro 2005-05-06 16:31:01 UTC
I'm seeing the same problem in 2.6.11-1.1286.

It looks like line 3 is similarly buggered. It should read:

    from:
      mount -t proc /proc /proc
    to:
      mount -t proc none /proc

And in case sgodsell's post wasn't entirely clear, the correct /sys and /dev
lines are:

      mount -t sysfs none /sys
      mount -o mode=0755 -t tmpfs none /dev

Given that this bug isn't an obscure machine-dependent issue, one wonders how it
is possible to push an update RPM that obviously hasn't been tested?

Comment 8 Jonathan S. Shapiro 2005-05-06 16:32:41 UTC
Priority of this should be bumped to "high", because outsider testing is
substantially impeded until this is resolved.

Comment 9 Peter Jones 2005-05-16 19:07:17 UTC
This should be fixed with an updated udev.


Note You need to log in before you can comment on or make changes to this bug.