Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156908 - strace -f kmodule -d panics kernel
Summary: strace -f kmodule -d panics kernel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 156045 157141 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 04:44 UTC by Alexandre Oliva
Modified: 2015-01-04 22:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-04 22:58:18 UTC


Attachments (Terms of Use)
patch posted to lkml that allegedly fixes the problem (deleted)
2005-05-05 19:36 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2005-05-05 04:44:32 UTC
If you run:

root# strace -f kmodule -d 

on kernel 2.6.11-1.1284_FC4 (UP i686), the output will end with something like:

clone(Process 4326 attached
child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xb7fcb708) = 4326
[pid  4320] exit_group(0)               = ?

and the box may freeze, after leaving the following trail in /var/log/messages:

Unable to handle kernel NULL pointer dereference at virtual address 00000000
 printing eip:
00000000
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: nfsd exportfs lockd parport_pc
lp parport autofs4 i2c_dev i2c_core rfcomm l2cap bluetooth tun sunrpc pcmcia
ipt_REJECT ipt_LOG ipt_state iptable_filter iptable_nat ip_conntrack
iptable_mangle ip_tables video button battery ac md5 ipv6 yenta_socket
rsrc_nonstatic pcmcia_core snd_maestro3 snd_ac97_codec snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd_page_alloc snd soundcore e100 mii floppy dm_snapshot dm_zero
dm_mirror ext3 jbd dm_mod usb_storage uhci_hcd sbp2 ohci1394 ieee1394 sd_mod
scsi_mod
CPU:    0
EIP:    0060:[<00000000>]    Not tainted VLI
EFLAGS: 00010286   (2.6.11-1.1284_FC4)
EIP is at _stext+0x3feffdd8/0x8
eax: d42ee000   ebx: 01200011   ecx: 00000000   edx: 00000000
esi: d3b01000   edi: d46b0bc4   ebp: d42ee000   esp: d42eefc4
ds: 007b   es: 007b   ss: 0068
Process kmodule (pid: 4326, threadinfo=d42ee000 task=d3b01000)
Stack: 01202011 00000000 00000000 00000000 b7fcb708 bfbec4cc 00000000 c010007b
       c010007b 00000078 00fd3402 00000073 00000282 bfbec474 0000007b
Call Trace:
Code:  Bad EIP value.
 <0>Fatal exception: panic in 5 seconds

Comment 1 Alexandre Oliva 2005-05-05 19:36:14 UTC
Created attachment 114066 [details]
patch posted to lkml that allegedly fixes the problem

As luck would have it, Krzysztof Halasa <khc@pm.waw.pl> ran into the same
problem earlier today and posted about it to lkml.  Alexander Nyberg
<alexn@telia.com> posted the attached e-mail containing a patch, and Krzysztof
confirmed it fixed the bug.

Comment 2 Roland McGrath 2005-05-09 08:08:27 UTC
*** Bug 156045 has been marked as a duplicate of this bug. ***

Comment 3 Dave Jones 2005-05-10 20:17:17 UTC
this patch is included in -rc4, so 1290 and above should have it.
(you can grab it early from http://people.redhat.com/davej/kernels/Fedora/FC4)

it'll be in tomorrows rawhide


Comment 4 Dave Jones 2005-05-10 21:27:22 UTC
*** Bug 157141 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.