Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156903 - --whatrequires doesn't return complete information
Summary: --whatrequires doesn't return complete information
Keywords:
Status: CLOSED DUPLICATE of bug 142651
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-05 02:09 UTC by n fuhriman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 21:28:05 UTC


Attachments (Terms of Use)

Description n fuhriman 2005-05-05 02:09:35 UTC
Description of problem: 
--what requires doesn't return complete information. it lists all rpms that 
require the specific package. it however doesn't list rpms that requires it's 
other files or provides. I've tried working around this by getting a full list 
of provides and requires but even this doesn't work as programs (raidtools) 
require packages that don't exist as provides (rpmlib) 
 
Version-Release number of selected component (if applicable): 
every version has this probelm 
 
How reproducible: 
every time 
 
Steps to Reproduce: 
1.make sure that vte and rhgb are installed  
2. rpm -q --whatrequires vte (rhgb is NOT returned) 
3. rpm -e vte (this throws an error saying rhgb requires vte) 
   
Actual results: 
--whatrequires doesn't return rhgb 
 
Expected results: 
--whatrequires should return rhgb 
 
Additional info: 
there are additional packages like this. rhgb and vte are just examples.

Comment 1 Paul Nasrat 2005-05-05 14:32:58 UTC
It's indirectly required as opposed to by name.  whatrequires looks at exact
name try:

rpm --provides -q vte | xargs rpm --whatrequires -q | grep -v no\ package | uniq


Comment 2 Paul Nasrat 2005-11-28 21:28:05 UTC

*** This bug has been marked as a duplicate of 142651 ***


Note You need to log in before you can comment on or make changes to this bug.