Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1569 - If 'setup' RPM can't be installed, install should stop.
Summary: If 'setup' RPM can't be installed, install should stop.
Keywords:
Status: CLOSED DUPLICATE of bug 17928
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-17 16:21 UTC by Daniel Rogers
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-10-04 18:25:33 UTC


Attachments (Terms of Use)

Description Daniel Rogers 1999-03-17 16:21:35 UTC
If the 'setup' RPM can't be installed, the installation
shoud stop.  Currently, the install continues, resulting in
the 'dev' and 'MAKEDEV' packages not installing, and ending
up with a system that is unbootable.

If you manually install the 'dev' and 'MAKEDEV' packages by
touching /etc/passwd and /etc/group, you'll end up with a
system that'll boot (with some complaining), but that you'll
be unable to log in to (obviously), or reboot cleanly,
because there is no uid 0 user in /etc/passwd, and a
ctrl-alt-del gives you "You don't exist.  Go away."  The
only way to reboot is a hardware reboot.

Comment 1 Chris Siebenmann 1999-03-18 00:25:59 UTC
This is probably a manifestation of a general RPM bug, where it only
statically checks Prereq: and Requires: requirements of RPMs. If one
of the packages fails to install, RPM does not notice that some
requirements are no longer met and continues to install RPMs.

Comment 2 Matt Wilson 1999-03-26 02:18:59 UTC
the new RPM transactions require an entire transaction to complete in
order to be successful.  This means that we should really abort the
entire install in a failure like this, but instead well trudge along.
We may revisit the problem later.  If you've done something where the
setup package isn't getting installed, you're _going_ to run into
problems (for now)

Comment 3 Jay Turner 2000-02-10 19:00:59 UTC
Issue has been added to list of features for future releases.

Comment 4 Michael Fulbright 2000-09-19 23:09:54 UTC
How can we reproduce this problem?

Comment 5 Daniel Rogers 2000-09-19 23:13:49 UTC
I had this problem when trying to do an FTP install where I got the error that
the installer was unable to set the FTP server to PASV mode.  It then skipped
the first package and continued merrily along.

Dan.


Comment 6 Michael Fulbright 2000-09-26 16:10:34 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 7 Michael Fulbright 2000-09-26 16:56:15 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 8 Michael Fulbright 2000-10-04 18:25:14 UTC
Ok this appears to have been a problem before...

Comment 9 Michael Fulbright 2000-10-04 18:25:30 UTC

*** This bug has been marked as a duplicate of 17928 ***


Note You need to log in before you can comment on or make changes to this bug.